<!DOCTYPE html><html class="avada-html-layout-wide avada-html-header-position-top" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><head><meta http-equiv="X-UA-Compatible" content="IE=edge" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><title>13 November, 2020, Friday, 32nd Week, Ordinary Time &#8211; The Roman Catholic Archdiocese of Singapore</title><link rel="alternate" type="text/calendar" title="The Roman Catholic Archdiocese of Singapore &raquo; iCal Feed" href="https://www.catholic.sg/events/?ical=1" /><link rel="shortcut icon" href="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-20.png" type="image/x-icon" /><link rel="apple-touch-icon" href="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-57-1.png"><link rel="apple-touch-icon" sizes="114x114" href="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-114.png"><link rel="apple-touch-icon" sizes="72x72" href="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-72.png"><link rel="apple-touch-icon" sizes="144x144" href="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-144.png"><meta property="og:title" content="13 November, 2020, Friday, 32nd Week, Ordinary Time" /><meta property="og:type" content="article" /><meta property="og:url" content="https://www.catholic.sg/13-november-2020-friday-32nd-week-ordinary-time/" /><meta property="og:site_name" content="The Roman Catholic Archdiocese of Singapore" /><meta property="og:description" content="LIVING IN TRUTH AND LOVESCRIPTURE READINGS:
In the first reading, St John underscores the importance of walking in the truth.  What does it mean to walk in the truth?  It entails knowing the truth and walking in love.  In John&#039;s understanding, walking in the truth" /><meta property="og:image" content="https://www.catholic.sg/wp-content/uploads/2020/08/AB-SR-FB.png" /><style id="fvm-header-12" media="only screen and (max-width: 644px)">.fusion-blog-layout-grid-6 .fusion-post-grid,.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post{width:100%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-landscape .fusion-masonry-element-container,.fusion-grid-6 .fusion-grid-column.fusion-element-landscape .fusion-masonry-element-container,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape .fusion-masonry-element-container{padding-top:65%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-grid .fusion-masonry-element-container,.fusion-grid-6 .fusion-grid-column.fusion-element-grid .fusion-masonry-element-container,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-grid .fusion-masonry-element-container{padding-top:100%!important}</style><style id="fvm-header-13" media="only screen and (max-width: 735px)">.fusion-blog-layout-grid .fusion-post-grid,.fusion-grid-column,.fusion-portfolio-post{width:100%!important}.fusion-blog-layout-grid .fusion-post-grid.fusion-element-landscape .fusion-masonry-element-container,.fusion-grid-column.fusion-element-landscape .fusion-masonry-element-container,.fusion-portfolio-post.fusion-element-landscape .fusion-masonry-element-container{padding-top:65%!important}.fusion-blog-layout-grid .fusion-post-grid.fusion-element-grid .fusion-masonry-element-container,.fusion-grid-column.fusion-element-grid .fusion-masonry-element-container,.fusion-portfolio-post.fusion-element-grid .fusion-masonry-element-container{padding-top:100%!important}.fusion-portfolio-grid:not(.fusion-portfolio-text) .fusion-portfolio-post .fusion-image-wrapper{display:block;text-align:center}.fusion-blog-layout-grid-6 .fusion-post-grid,.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post{width:50%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-landscape,.fusion-grid-6 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape{width:100%!important}</style><style id="fvm-header-14" media="only screen and (min-width: 735px) and (max-width: 826px)">.fusion-blog-layout-grid-6 .fusion-post-grid,.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post{width:33.3333333333%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-landscape,.fusion-grid-6 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape{width:66.6666666666%!important}.fusion-blog-layout-grid-3 .fusion-post-grid,.fusion-blog-layout-grid-4 .fusion-post-grid,.fusion-blog-layout-grid-5 .fusion-post-grid,.fusion-grid-3 .fusion-grid-column,.fusion-grid-4 .fusion-grid-column,.fusion-grid-5 .fusion-grid-column,.fusion-portfolio-five .fusion-portfolio-post,.fusion-portfolio-four .fusion-portfolio-post,.fusion-portfolio-masonry .fusion-portfolio-post,.fusion-portfolio-three .fusion-portfolio-post{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-4 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape,.fusion-grid-3 .fusion-grid-column.fusion-element-landscape,.fusion-grid-4 .fusion-grid-column.fusion-element-landscape,.fusion-grid-5 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-five .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-four .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-masonry .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-three .fusion-portfolio-post.fusion-element-landscape{width:100%!important}</style><style id="fvm-header-15" media="only screen and (min-width: 826px) and (max-width: 917px)">.fusion-blog-layout-grid-6 .fusion-post-grid,.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post{width:25%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-landscape,.fusion-grid-6 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid,.fusion-blog-layout-grid-4 .fusion-post-grid,.fusion-blog-layout-grid-5 .fusion-post-grid,.fusion-grid-3 .fusion-grid-column,.fusion-grid-4 .fusion-grid-column,.fusion-grid-5 .fusion-grid-column,.fusion-portfolio-five .fusion-portfolio-post,.fusion-portfolio-four .fusion-portfolio-post,.fusion-portfolio-three .fusion-portfolio-post{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-4 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape,.fusion-grid-3 .fusion-grid-column.fusion-element-landscape,.fusion-grid-4 .fusion-grid-column.fusion-element-landscape,.fusion-grid-5 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-five .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-four .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-three .fusion-portfolio-post.fusion-element-landscape{width:100%!important}</style><style id="fvm-header-16" media="only screen and (min-width: 917px) and (max-width: 1008px)">.fusion-blog-layout-grid-6 .fusion-post-grid,.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post{width:20%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-landscape,.fusion-grid-6 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape{width:40%!important}.fusion-blog-layout-grid-4 .fusion-post-grid,.fusion-blog-layout-grid-5 .fusion-post-grid,.fusion-grid-4 .fusion-grid-column,.fusion-grid-5 .fusion-grid-column,.fusion-portfolio-five .fusion-portfolio-post,.fusion-portfolio-four .fusion-portfolio-post{width:33.3333333333%!important}.fusion-blog-layout-grid-4 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape,.fusion-grid-4 .fusion-grid-column.fusion-element-landscape,.fusion-grid-5 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-five .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-four .fusion-portfolio-post.fusion-element-landscape{width:66.6666666666%!important}</style><style id="fvm-header-17" media="only screen and (min-width: 1008px) and (max-width: 1099px)">.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post,.grid-layout-6 .fusion-post-grid{width:20%!important}.fusion-grid-6 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape,.grid-layout-6 .fusion-post-grid.fusion-element-landscape{width:40%!important}.fusion-blog-layout-grid-5 .fusion-post-grid,.fusion-grid-5 .fusion-grid-column,.fusion-portfolio-five .fusion-portfolio-post{width:25%!important}.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape,.fusion-grid-5 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-five .fusion-portfolio-post.fusion-element-landscape{width:50%!important}</style><style id="fvm-header-18" media="only screen and (min-width: 801px)">.fusion-icon-only-link .menu-title{display:none}.fusion-main-menu>ul>li>a.fusion-icon-only-link>.fusion-megamenu-icon{padding:0}body.side-header-right.layout-boxed-mode #side-header{position:absolute;top:0;right:0}body.side-header-right.layout-boxed-mode #side-header .side-header-wrapper{position:fixed;width:var(--side_header_width)}.fusion-mobile-menu-search{display:none!important}.fusion-header-wrapper .fusion-header .fusion-logo-background:after{top:calc((var(--header_padding-top)) * -1);border-top:var(--header_padding-top) solid var(--logo_background_color);border-bottom:var(--header_padding-bottom) solid var(--logo_background_color)}.avada-has-logo-background.avada-responsive.fusion-top-header:not(.fusion-header-layout-v4):not(.fusion-header-layout-v5) .fusion-header .fusion-logo-background{display:-ms-inline-flexbox;display:inline-flex;position:relative;background-color:var(--logo_background_color)}.avada-has-logo-background.avada-responsive.fusion-top-header:not(.fusion-header-layout-v4):not(.fusion-header-layout-v5) .fusion-header-wrapper .fusion-header .fusion-logo-background:after{content:"";pointer-events:none;position:absolute;left:0;width:100%;height:100%}.avada-has-logo-background.avada-responsive.fusion-top-header:not(.fusion-header-layout-v4):not(.fusion-header-layout-v5):not(.fusion-header-layout-v7) .fusion-header .fusion-logo-background{float:var(--logo_alignment)}.avada-has-logo-background.avada-responsive.fusion-top-header:not(.fusion-header-layout-v4):not(.fusion-header-layout-v5):not(.fusion-header-layout-v7).avada-has-header-100-width .fusion-logo-center .fusion-header,.avada-has-logo-background.avada-responsive.fusion-top-header:not(.fusion-header-layout-v4):not(.fusion-header-layout-v5):not(.fusion-header-layout-v7).avada-has-header-100-width .fusion-logo-left .fusion-header{padding-left:0}.avada-has-logo-background.avada-responsive.fusion-top-header:not(.fusion-header-layout-v4):not(.fusion-header-layout-v5):not(.fusion-header-layout-v7).avada-has-header-100-width .fusion-logo-right .fusion-header{padding-right:0}.avada-has-logo-background.avada-responsive.fusion-top-header:not(.fusion-header-layout-v4):not(.fusion-header-layout-v5).mobile-logo-pos-center .fusion-header .fusion-logo-background{float:left}.avada-has-logo-background.fusion-header-layout-v6.mobile-logo-pos-right.avada-has-header-100-width .fusion-header{-ms-flex-order:2;order:2}.avada-has-logo-background.fusion-header-layout-v6.mobile-logo-pos-right .fusion-header .fusion-logo-background{-ms-flex-order:2;order:2}.avada-has-logo-background:not(.fusion-top-header) .side-header-content.fusion-logo-center,.avada-has-logo-background:not(.fusion-top-header) .side-header-content.fusion-logo-left,.avada-has-logo-background:not(.fusion-top-header) .side-header-content.fusion-logo-right{background-color:var(--logo_background_color)}html.avada-header-color-not-opaque .fusion-header,html.avada-header-color-not-opaque .fusion-secondary-header{border-top:none}html.avada-header-color-not-opaque .fusion-header-v1 .fusion-header,html.avada-header-color-not-opaque .fusion-secondary-main-menu{border:none}html.avada-header-color-not-opaque .fusion-header-wrapper{position:absolute;z-index:10000}html.avada-header-color-not-opaque .fusion-header-wrapper .fusion-header{background-image:none}html.avada-header-color-not-opaque .layout-boxed-mode .fusion-header-wrapper{width:100%;max-width:var(--site_width)}html.avada-header-color-not-opaque .layout-wide-mode .fusion-header-wrapper{left:0;right:0}.avada-has-logo-background.avada-sticky-shrinkage:not(.fusion-header-layout-v4):not(.fusion-header-layout-v5) .fusion-header-wrapper.fusion-is-sticky .fusion-header .fusion-logo-background:after{transition:border-width .25s ease-in-out;border-bottom-width:0}.avada-has-logo-background.fusion-top-header.fusion-header-layout-v7:not(.avada-menu-highlight-style-background) .fusion-header .fusion-logo-background{padding-right:0;margin-right:var(--nav_padding)}.avada-has-logo-background.fusion-top-header.fusion-header-layout-v7:not(.avada-menu-highlight-style-background) .fusion-is-sticky .fusion-header .fusion-logo-background{padding-right:0;margin-right:var(--header_sticky_nav_padding)}</style><style id="fvm-header-20" media="only screen and (min-device-width: 768px) and (max-device-width: 1024px) and (orientation: portrait)">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</style><style id="fvm-header-21" media="only screen and (min-device-width: 768px) and (max-device-width: 1024px) and (orientation: landscape)">.fullwidth-box{background-attachment:scroll!important}.fullwidth-box .fullwidth-faded{background-attachment:scroll!important}.avada-footer-fx-bg-parallax .fusion-footer-widget-area{background-attachment:initial;margin:0}.avada-footer-fx-bg-parallax #main{margin-bottom:0}#main,.fullwidth-box,.fusion-footer-widget-area,.page-title-bar,body{background-attachment:scroll!important}.avada-responsive.rtl .fusion-header-v1 .fusion-main-menu>ul>li,.avada-responsive.rtl .fusion-header-v2 .fusion-main-menu>ul>li,.avada-responsive.rtl .fusion-header-v3 .fusion-main-menu>ul>li,.avada-responsive.rtl .fusion-header-v4 .fusion-main-menu>ul>li,.avada-responsive.rtl .fusion-header-v5 .fusion-main-menu>ul>li,.avada-responsive.rtl .fusion-header-v7 .fusion-main-menu>ul>li{padding-left:var(--mobile_nav_padding)}.avada-responsive:not(.rtl) .fusion-header-v1 .fusion-main-menu>ul>li,.avada-responsive:not(.rtl) .fusion-header-v2 .fusion-main-menu>ul>li,.avada-responsive:not(.rtl) .fusion-header-v3 .fusion-main-menu>ul>li,.avada-responsive:not(.rtl) .fusion-header-v4 .fusion-main-menu>ul>li,.avada-responsive:not(.rtl) .fusion-header-v5 .fusion-main-menu>ul>li,.avada-responsive:not(.rtl) .fusion-header-v7 .fusion-main-menu>ul>li{padding-right:var(--mobile_nav_padding)}</style><style id="fvm-header-22" media="only screen and (max-width: 800px)">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</style><style id="fvm-header-23" media="only screen and (max-width: 640px)">.fusion-body .fusion-page-title-bar{max-height:none}.fusion-body .fusion-page-title-bar h1{margin:0}.fusion-body .fusion-blog-layout-medium .fusion-post-slideshow{float:none;margin:0 0 20px;width:auto;height:auto;-ms-flex:0 1 100%;flex:0 1 100%}.fusion-body .fusion-blog-layout-medium .fusion-post-content{-ms-flex:0 1 100%;flex:0 1 100%}.fusion-body .fusion-blog-layout-large-alternate .fusion-post-content{margin:0}.fusion-blog-layout-large .fusion-meta-info .fusion-alignleft,.fusion-blog-layout-large .fusion-meta-info .fusion-alignright,.fusion-blog-layout-medium .fusion-meta-info .fusion-alignleft,.fusion-blog-layout-medium .fusion-meta-info .fusion-alignright{display:block;float:none;margin:0;width:100%}.fusion-blog-layout-large-alternate .fusion-date-and-formats{margin-bottom:35px}.fusion-blog-layout-medium-alternate .has-post-thumbnail .fusion-post-slideshow{display:inline-block;float:none;margin-right:0;max-width:197px}.fusion-blog-layout-grid .fusion-post-grid{position:static;width:100%}.flex-direction-nav,.wooslider-direction-nav,.wooslider-pauseplay{display:none}.share-box ul li{margin-bottom:10px;margin-right:15px}.share-box .social-networks li{margin-right:20px!important}.buttons a{margin-right:5px}.ls-avada .ls-nav-next,.ls-avada .ls-nav-prev{display:none!important}#wrapper .ei-slider{width:100%!important;height:200px!important}#wrapper .share-box h4{display:block;float:none;line-height:20px!important;margin-top:0;padding:0;margin-bottom:10px}.page-template-contact-php .fusion-google-map{height:270px!important}.timeline-icon{display:none!important}.timeline-layout{padding-top:0!important}.portfolio-masonry .portfolio-item{width:100%!important}.table-1 table,.tkt-slctr-tbl-wrap-dv table{border-collapse:collapse;border-spacing:0;width:100%}.table-1 td,.table-1 th,.tkt-slctr-tbl-wrap-dv td,.tkt-slctr-tbl-wrap-dv th{white-space:nowrap}.table-2 table{border-collapse:collapse;border-spacing:0;width:100%}.table-2 td,.table-2 th{white-space:nowrap}#main,.footer-area,.page-title-bar,body{background-attachment:scroll!important}.tfs-slider[data-animation=slide]{height:auto!important}.fusion-sharing-box .fusion-social-networks{float:none;display:block;width:100%;text-align:left}#content{width:100%!important;margin-left:0!important}.sidebar{width:100%!important;float:none!important;margin-left:0!important;clear:both}.fusion-hide-on-mobile{display:none}.fusion-blog-layout-timeline{padding-top:0}.fusion-blog-layout-timeline .fusion-post-timeline{float:none;width:100%}.fusion-blog-layout-timeline .fusion-timeline-date{margin-bottom:0;margin-top:2px}.fusion-timeline-arrow,.fusion-timeline-circle,.fusion-timeline-icon,.fusion-timeline-line{display:none}</style><style id="fvm-header-24" media="only screen and (max-width: 782px)">.admin-bar p.woocommerce-store-notice,body.admin-bar #wrapper .fusion-sliding-bar-position-top,body.layout-boxed-mode.side-header-right .fusion-sliding-bar-position-top{top:46px}body.fusion-blank-page.admin-bar{top:45px}html #wpadminbar{z-index:99999!important;position:fixed!important}</style><style id="fvm-header-25" media="only screen and (max-width: 768px)">.fusion-tabs.vertical-tabs .tab-pane{max-width:none!important}</style><style id="fvm-header-26" media="only screen and (min-width: 800px)">.ilightbox-holder.supportTouch div.ilightbox-container{overflow:visible}.widget.tweets.fusion-widget-align-right .jtwt .jtwt_tweet{padding-left:0;padding-right:45px}.widget.tweets.fusion-widget-align-right .jtwt .jtwt_tweet:before{margin-left:0;right:0}.widget.tweets.fusion-widget-align-center .jtwt .jtwt_tweet{padding:0}.widget.tweets.fusion-widget-align-center .jtwt .jtwt_tweet:before{top:0;position:relative;margin:0}.widget.tribe-events-list-widget.fusion-widget-align-right .tribe-events-list-widget-events{-ms-flex-pack:end;justify-content:end}.widget.tribe-events-list-widget.fusion-widget-align-center .tribe-events-list-widget-events{-ms-flex-pack:center;justify-content:center}.fusion-body .fusion-footer-widget-area-center .widget.tweets:not(.fusion-widget-align-left):not(.fusion-widget-align-right) .jtwt .jtwt_tweet{padding:0}.fusion-body .fusion-footer-widget-area-center .widget.tweets:not(.fusion-widget-align-left):not(.fusion-widget-align-right) .jtwt .jtwt_tweet:before{top:0;position:relative;margin:0}.no-overflow-y body{padding-right:9px!important}.no-overflow-y .modal{overflow-y:hidden}.no-overflow-y .fusion-sliding-bar-position-bottom,.no-overflow-y .fusion-sliding-bar-position-top{right:9px}.no-desktop-totop .to-top-container{display:none}</style><style id="fvm-header-27" media="only screen and (max-device-width: 640px)">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</style><style id="fvm-header-28" media="only screen and (max-width: 800px)">.gform_wrapper .left_label input.medium,.gform_wrapper .left_label select.medium,.gform_wrapper .right_label input.medium,.gform_wrapper .right_label select.medium{width:35%!important}.wpcf7-form .wpcf7-number,.wpcf7-form .wpcf7-quiz,.wpcf7-form .wpcf7-text,.wpcf7-form textarea{float:none!important;width:100%!important;box-sizing:border-box}.ei-title{position:absolute;right:0;margin-right:0;width:100%;text-align:center;top:28%;padding:5px 0}.ei-title h2,.ei-title h3{text-align:center}#wrapper .ei-title h2{font-size:20px;line-height:24px}#wrapper .ei-title h3{font-size:15px;line-height:30px}</style><style id="fvm-header-29" media="only screen and (max-width: 768px)">#tribe-events-content-wrapper #tribe_events_filters_wrapper{height:auto}#tribe-events-content-wrapper #tribe_events_filters_wrapper #tribe_events_filter_control{width:100%}#tribe-events-content-wrapper #tribe_events_filters_wrapper #tribe_events_filter_control .tribe-reset-icon{line-height:normal}#tribe-events-content-wrapper #tribe_events_filters_wrapper #tribe_events_filter_control #tribe_events_filters_reset{margin-top:10px}.tribe-filters-open #tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal{background-color:transparent}.tribe-filters-open #tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe-events-filters-content{padding-top:0}.tribe-filters-open #tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal:after,.tribe-filters-open #tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal:before{background-color:transparent}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal #tribe_events_filters_form{width:100%;float:none;margin:15px 0}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe-events-filters-label{margin-bottom:10px}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe_events_filters_show_filters{height:auto;line-height:1;border:none}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe_events_filters_close_filters{margin-top:0}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe-events-filters-legend{padding:0}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe-events-filters-content{display:block}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe_events_filter_item{margin:0}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe_events_filter_item .tribe-events-filters-group-heading{padding:15px}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe-events-filter-group ul li{padding:10px 20px}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe_events_slider_val{position:static}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe-filter-status{display:none}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe-events-filters-mobile-controls{margin-left:-10px;margin-right:-10px}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-horizontal .tribe-reset-icon{line-height:1;padding-top:2px}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-vertical .tribe_events_filters_show_filters{margin:0;background-color:transparent;height:auto;line-height:1;color:inherit}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-vertical #tribe_events_filters_reset{margin-bottom:0}#tribe-events-content-wrapper #tribe_events_filters_wrapper.tribe-events-filters-vertical .tribe-reset-icon{line-height:1}#tribe-events-footer:after,#tribe-events-footer:before,#tribe-events-header:after,#tribe-events-header:before{background-color:transparent!important}</style><style id="fvm-header-30" media="only screen and (max-width: 800px)">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</style><style id="fvm-header-31" media="only screen and (min-device-width: 768px) and (max-device-width: 1024px) and (orientation: portrait)">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</style><style id="fvm-header-32" media="only screen and (max-device-width: 640px)">.fusion-columns .fusion-column{float:none;width:100%!important;margin:0 0 50px;-webkit-box-sizing:border-box;box-sizing:border-box}.fusion-blog-layout-large .fusion-meta-info .fusion-alignleft,.fusion-blog-layout-large .fusion-meta-info .fusion-alignright,.fusion-blog-layout-medium .fusion-meta-info .fusion-alignleft,.fusion-blog-layout-medium .fusion-meta-info .fusion-alignright{display:block;float:none;margin:0;width:100%}.fusion-blog-layout-medium .fusion-post-slideshow{margin:0 0 20px 0;height:auto;width:auto;-webkit-box-flex:1;-ms-flex:1 0 100%;flex:1 0 100%}.fusion-blog-layout-medium .fusion-post-content{-webkit-box-flex:0;-ms-flex:0 1 100%;flex:0 1 100%}.fusion-blog-layout-large-alternate .fusion-date-and-formats{margin-bottom:35px}.fusion-blog-layout-large-alternate .fusion-post-content{margin:0}.fusion-blog-layout-medium-alternate .has-post-thumbnail .fusion-post-slideshow{display:inline-block;margin-right:0;max-width:197px}.fusion-blog-layout-grid .fusion-post-grid{position:static;width:100%}.fusion-blog-layout-timeline{padding-top:0}.fusion-blog-layout-timeline .fusion-post-timeline{float:none;width:100%}.fusion-blog-layout-timeline .fusion-timeline-date{margin-bottom:0;margin-top:2px}.fusion-timeline-arrow,.fusion-timeline-circle,.fusion-timeline-icon,.fusion-timeline-line{display:none}</style><style id="fvm-header-33" media="only screen and (max-width: 644px)">.fusion-blog-layout-grid-6 .fusion-post-grid{width:100%!important}</style><style id="fvm-header-34" media="only screen and (max-width: 735px)">.fusion-blog-layout-grid .fusion-post-grid{width:100%!important}.fusion-blog-layout-grid-6 .fusion-post-grid{width:50%!important}.fusion-blog-layout-grid-6 .fusion-element-landscape{width:100%!important}</style><style id="fvm-header-35" media="only screen and (min-width: 735px) and (max-width: 826px)">.fusion-blog-layout-grid-6 .fusion-post-grid{width:33.33333333%!important}.fusion-blog-layout-grid-6 .fusion-element-landscape{width:66.66666667%!important}.fusion-blog-layout-grid-3 .fusion-post-grid,.fusion-blog-layout-grid-4 .fusion-post-grid,.fusion-blog-layout-grid-5 .fusion-post-grid{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-4 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape{width:100%!important}</style><style id="fvm-header-36" media="only screen and (min-width: 826px) and (max-width: 917px)">.fusion-blog-layout-grid-6 .fusion-post-grid{width:25%!important}.fusion-blog-layout-grid-6 .fusion-element-landscape{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid,.fusion-blog-layout-grid-4 .fusion-post-grid,.fusion-blog-layout-grid-5 .fusion-post-grid{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-4 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape{width:100%!important}</style><style id="fvm-header-37" media="only screen and (min-width: 917px) and (max-width: 1008px)">.fusion-blog-layout-grid-6 .fusion-post-grid{width:20%!important}.fusion-blog-layout-grid-6 .fusion-element-landscape{width:40%!important}.fusion-blog-layout-grid-5 .fusion-post-grid{width:33.33333333%!important}.fusion-blog-layout-grid-5 .fusion-element-landscape{width:66.66666667%!important}.fusion-blog-layout-grid-4 .fusion-post-grid{width:33.33333333%!important}.fusion-blog-layout-grid-4 .fusion-element-landscape{width:66.66666667%!important}</style><style id="fvm-header-38" media="only screen and (min-width: 1008px) and (max-width: 1099px)">.fusion-blog-layout-grid-6 .fusion-post-grid{width:20%!important}.fusion-blog-layout-grid-6 .fusion-element-landscape{width:40%!important}.fusion-blog-layout-grid-5 .fusion-post-grid{width:25%!important}.fusion-blog-layout-grid-5 .fusion-element-landscape{width:50%!important}</style><link rel='stylesheet' id='fvm-header-0-css' href='https://www.catholic.sg/wp-content/uploads/cache/fvm/1605152371/out/header-add983c170f04e297c33a0b44ba25deaa695e10e.min.css' type='text/css' media='all' /><link rel='stylesheet' id='jquery-datatables-css' href='https://cdn.datatables.net/1.10.20/css/jquery.dataTables.min.css' type='text/css' media='all' /><link rel='stylesheet' id='datatables-buttons-css' href='https://cdn.datatables.net/buttons/1.6.1/css/buttons.dataTables.min.css' type='text/css' media='all' /><link rel='stylesheet' id='datatables-select-css' href='https://cdn.datatables.net/select/1.3.1/css/select.dataTables.min.css' type='text/css' media='all' /><link rel='stylesheet' id='datatables-fixedheader-css' href='https://cdn.datatables.net/fixedheader/3.1.6/css/fixedHeader.dataTables.min.css' type='text/css' media='all' /><link rel='stylesheet' id='datatables-fixedcolumns-css' href='https://cdn.datatables.net/fixedcolumns/3.3.0/css/fixedColumns.dataTables.min.css' type='text/css' media='all' /><link rel='stylesheet' id='datatables-responsive-css' href='https://cdn.datatables.net/responsive/2.2.3/css/responsive.dataTables.min.css' type='text/css' media='all' /><link rel='stylesheet' id='fvm-header-7-css' href='https://www.catholic.sg/wp-content/uploads/cache/fvm/1605152371/out/header-ea508c2a3b4dc19057f8eb2193d052fa7491a637.min.css' type='text/css' media='all' /> <!--[if IE]><link
rel='stylesheet' id='avada-IE-css'  href='https://www.catholic.sg/wp-content/themes/Avada/assets/css/ie.min.css' type='text/css' media='all' /><style id='avada-IE-inline-css' type='text/css'>.avada-select-parent .select-arrow{background-color:#fff}.select-arrow{background-color:#fff}</style><![endif]--><link rel='stylesheet' id='fvm-header-9-css' href='https://www.catholic.sg/wp-content/uploads/cache/fvm/1605152371/out/header-1b11ff79e8c8b4c3d0eb584f92922cb8ce4a8fba.min.css' type='text/css' media='all' /><link rel='stylesheet' id='font-awesome-official-css' href='https://use.fontawesome.com/releases/v5.9.0/css/all.css' type='text/css' media='all' integrity="sha384-i1LQnF23gykqWXg6jxC2ZbCbUMxyw5gLZY6UiUS98LYV5unm8GWmfkIS6jqJfb4E" crossorigin="anonymous" /><link rel='stylesheet' id='fvm-header-11-css' href='https://www.catholic.sg/wp-content/uploads/cache/fvm/1605152371/out/header-cff85d11cfedab6e96ffdc1f9bbd46786157e155.min.css' type='text/css' media='all' /><link rel='stylesheet' id='fvm-header-19-css' href='https://www.catholic.sg/wp-content/uploads/cache/fvm/1605152371/out/header-a08a53bcd2ee9a6b90bb42db14b61e0300aaaa31.min.css' type='text/css' media='only screen and (max-width: 800px)' /><link rel='stylesheet' id='fvm-header-39-css' href='https://www.catholic.sg/wp-content/uploads/cache/fvm/1605152371/out/header-14bfd28adb117da95a7440a815463e033bce8f38.min.css' type='text/css' media='all' /><link rel='stylesheet' id='font-awesome-official-v4shim-css' href='https://use.fontawesome.com/releases/v5.9.0/css/v4-shims.css' type='text/css' media='all' integrity="sha384-zpflLcSaYRmTsnK2LTOdvChgML+Tt/4aE2szcblLVBXd8Jq/HGz6rhZqZ+4TkK75" crossorigin="anonymous" /><style id='font-awesome-official-v4shim-inline-css' type='text/css'>@font-face{font-family:"FontAwesome";src:url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.eot"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.eot?#iefix") format("embedded-opentype"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.woff2") format("woff2"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.woff") format("woff"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.ttf") format("truetype"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.svg#fontawesome") format("svg")}@font-face{font-family:"FontAwesome";src:url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.eot"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.eot?#iefix") format("embedded-opentype"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.woff2") format("woff2"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.woff") format("woff"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.ttf") format("truetype"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.svg#fontawesome") format("svg")}@font-face{font-family:"FontAwesome";src:url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.eot"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.eot?#iefix") format("embedded-opentype"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.woff2") format("woff2"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.woff") format("woff"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.ttf") format("truetype"), url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.svg#fontawesome") format("svg");unicode-range:U+F004-F005,U+F007,U+F017,U+F022,U+F024,U+F02E,U+F03E,U+F044,U+F057-F059,U+F06E,U+F070,U+F075,U+F07B-F07C,U+F080,U+F086,U+F089,U+F094,U+F09D,U+F0A0,U+F0A4-F0A7,U+F0C5,U+F0C7-F0C8,U+F0E0,U+F0EB,U+F0F3,U+F0F8,U+F0FE,U+F111,U+F118-F11A,U+F11C,U+F133,U+F144,U+F146,U+F14A,U+F14D-F14E,U+F150-F152,U+F15B-F15C,U+F164-F165,U+F185-F186,U+F191-F192,U+F1AD,U+F1C1-F1C9,U+F1CD,U+F1D8,U+F1E3,U+F1EA,U+F1F6,U+F1F9,U+F20A,U+F247-F249,U+F24D,U+F254-F25B,U+F25D,U+F267,U+F271-F274,U+F279,U+F28B,U+F28D,U+F2B5-F2B6,U+F2B9,U+F2BB,U+F2BD,U+F2C1-F2C2,U+F2D0,U+F2D2,U+F2DC,U+F2ED,U+F328,U+F358-F35B,U+F3A5,U+F3D1,U+F410,U+F4AD}</style> <script type='text/javascript'>ajaxurl='https://www.catholic.sg/wp-admin/admin-ajax.php';pf_nonce='af256ecc9b';</script><script type='text/javascript' src='https://www.catholic.sg/wp-content/uploads/cache/fvm/1605152371/out/header-6735b062dd6091ff49b72a3553c213f1e1656180.min.js'></script><script type='text/javascript' src='https://cdn.datatables.net/1.10.20/js/jquery.dataTables.min.js'></script><script type='text/javascript' src='https://cdn.datatables.net/buttons/1.6.1/js/dataTables.buttons.min.js'></script><script type='text/javascript' src='//cdn.datatables.net/buttons/1.6.1/js/buttons.colVis.min.js'></script><script type='text/javascript' src='//cdn.datatables.net/buttons/1.6.1/js/buttons.print.min.js'></script><script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/pdfmake/0.1.53/pdfmake.min.js'></script><script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/pdfmake/0.1.53/vfs_fonts.js'></script><script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/jszip/3.1.3/jszip.min.js'></script><script type='text/javascript' src='//cdn.datatables.net/buttons/1.6.1/js/buttons.html5.min.js'></script><script type='text/javascript' src='https://cdn.datatables.net/select/1.3.1/js/dataTables.select.min.js'></script><script type='text/javascript' src='https://cdn.datatables.net/fixedheader/3.1.6/js/dataTables.fixedHeader.min.js'></script><script type='text/javascript' src='https://cdn.datatables.net/fixedcolumns/3.3.0/js/dataTables.fixedColumns.min.js'></script><script type='text/javascript' src='https://cdn.datatables.net/responsive/2.2.3/js/dataTables.responsive.min.js'></script><script type='text/javascript'>var igsv_plugin_vars={"lang_dir":"https:\/\/www.catholic.sg\/wp-content\/plugins\/inline-google-spreadsheet-viewer\/languages","datatables_classes":".igsv-table:not(.no-datatables)","datatables_defaults_object":{"dom":"B<'clear'>lfrtip","buttons":["colvis","copy","csv","excel","pdf","print"]}};</script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/uploads/cache/fvm/1605152371/out/header-bc3063cc85fdfd6bd73cf14ba13388f83869315d.min.js'></script><script type='text/javascript' src='//www.google.com/jsapi'></script><script type='text/javascript'>var sibErrMsg={"invalidMail":"Please fill out valid email address","requiredField":"Please fill out required fields","invalidDateFormat":"Please fill out valid date format","invalidSMSFormat":"Please fill out valid phone number"};var ajax_sib_front_object={"ajax_url":"https:\/\/www.catholic.sg\/wp-admin\/admin-ajax.php","ajax_nonce":"b5c3c1a215","flag_url":"https:\/\/www.catholic.sg\/wp-content\/plugins\/mailin\/img\/flags\/"};</script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/uploads/cache/fvm/1605152371/out/header-baa9f715288a1f57aadba3bab22bff336366b833.min.js'></script><link rel='https://api.w.org/' href='https://www.catholic.sg/wp-json/' /><link rel="canonical" href="https://www.catholic.sg/13-november-2020-friday-32nd-week-ordinary-time/" /><link rel="alternate" type="application/json+oembed" href="https://www.catholic.sg/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.catholic.sg%2F13-november-2020-friday-32nd-week-ordinary-time%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.catholic.sg/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.catholic.sg%2F13-november-2020-friday-32nd-week-ordinary-time%2F&#038;format=xml" /> <script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};a2a_localize={Share:"Share",Save:"Save",Subscribe:"Subscribe",Email:"Email",Bookmark:"Bookmark",ShowAll:"Show All",ShowLess:"Show less",FindServices:"Find service(s)",FindAnyServiceToAddTo:"Instantly find any service to add to",PoweredBy:"Powered by",ShareViaEmail:"Share via email",SubscribeViaEmail:"Subscribe via email",BookmarkInYourBrowser:"Bookmark in your browser",BookmarkInstructions:"Press Ctrl+D or \u2318+D to bookmark this page",AddToYourFavorites:"Add to your favourites",SendFromWebOrProgram:"Send from any email address or email program",EmailProgram:"Email program",More:"More&#8230;",ThanksForSharing:"Thanks for sharing!",ThanksForFollowing:"Thanks for following!"};(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script> <script async src="https://www.googletagmanager.com/gtag/js?id=GA_TRACKING_ID"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','GA_TRACKING_ID');</script> <meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.catholic.sg"><link rel="https://theeventscalendar.com/" href="https://www.catholic.sg/wp-json/tribe/events/v1/" /><style type="text/css" id="css-fb-visibility">@media screen and (max-width: 640px){body:not(.fusion-builder-ui-wireframe) .fusion-no-small-visibility{display:none !important}}@media screen and (min-width: 641px) and (max-width: 1024px){body:not(.fusion-builder-ui-wireframe) .fusion-no-medium-visibility{display:none !important}}@media screen and (min-width: 1025px){body:not(.fusion-builder-ui-wireframe) .fusion-no-large-visibility{display:none !important}}</style><style type="text/css" id="wp-custom-css">div.fusion-menu-anchor{position:absolute;visibility:hidden;top:-145px}</style><style id="fusion-stylesheet-custom-css" type="text/css">body.single .post-slideshow .slides li{pointer-events:none}.fusion-footer-widget-area a:before{display:none}.fusion-footer-widget-area a{font-size:13px;line-height:80%}.fusion-footer-widget-area .widget-title{font-size:15px;font-weight:normal;font-style:normal}.size-recent-posts img{width:100%;height:225px;object-fit:cover}.attachment-full img{width:100%;height:auto;object-fit:cover}.fusion-post-slideshow{width:100%;overflow:hidden}.fusion-post-content-container, .recent-posts-content p{font-size:14px}.comment-form-cookies-consent{display:none}.tribe-common .tribe-events-c-search__button{background-color:#ffb728}.single-tribe_events .fusion-events-featured-image .fusion-events-single-title-content{display:none}</style> <script type="text/javascript">var doc=document.documentElement;doc.setAttribute('data-useragent',navigator.userAgent);</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-WCG6FB3');</script> </head><body class="post-template-default single single-post postid-123194 single-format-standard tribe-no-js page-template-var-www-vhosts-catholic-sg-httpdocs-wp-content-themes-avada-page-php tribe-theme-Avada tribe-events-filter-view tribe-filters-closed tribe-filters-horizontal tribe-filters-live-update fusion-image-hovers fusion-pagination-sizing fusion-button_size-xlarge fusion-button_type-flat fusion-button_span-no avada-image-rollover-circle-yes avada-image-rollover-no avada fusion-body ltr fusion-sticky-header no-mobile-slidingbar no-mobile-totop avada-has-rev-slider-styles fusion-disable-outline fusion-sub-menu-fade mobile-logo-pos-center layout-wide-mode avada-has-boxed-modal-shadow-none layout-scroll-offset-full avada-has-zero-margin-offset-top fusion-top-header menu-text-align-center mobile-menu-design-modern fusion-show-pagination-text fusion-header-layout-v5 avada-responsive avada-footer-fx-parallax-effect avada-menu-highlight-style-bar fusion-search-form-classic fusion-main-menu-search-dropdown fusion-avatar-square avada-sticky-shrinkage avada-dropdown-styles avada-blog-layout-large avada-blog-archive-layout-large avada-ec-not-100-width avada-ec-meta-layout-sidebar avada-header-shadow-yes avada-menu-icon-position-left avada-has-mobile-menu-search avada-has-main-nav-search-icon avada-has-breadcrumb-mobile-hidden avada-has-titlebar-hide avada-has-pagination-padding avada-flyout-menu-direction-right"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><div id="boxed-wrapper"><div class="fusion-sides-frame"></div><div id="wrapper" class="fusion-wrapper"><div id="home" style="position:relative;top:-1px;"></div> <header class="fusion-header-wrapper fusion-header-shadow"><div class="fusion-header-v5 fusion-logo-alignment fusion-logo-center fusion-sticky-menu- fusion-sticky-logo-1 fusion-mobile-logo-1 fusion-sticky-menu-and-logo fusion-header-menu-align-center fusion-mobile-menu-design-modern"><div class="fusion-secondary-header"><div class="fusion-row"><div class="fusion-alignright"> <nav class="fusion-secondary-menu" role="navigation" aria-label="Secondary Menu"></nav></div></div></div><div class="fusion-header-sticky-height"></div><div class="fusion-sticky-header-wrapper"><div class="fusion-header"><div class="fusion-row"><div class="fusion-logo" data-margin-top="0px" data-margin-bottom="5px" data-margin-left="0px" data-margin-right="0px"> <a class="fusion-logo-link" href="https://www.catholic.sg/"> <img src="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_tight_crop_280.png" srcset="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_tight_crop_280.png 1x" width="280" height="103" alt="The Roman Catholic Archdiocese of Singapore Logo" data-retina_logo_url="" class="fusion-standard-logo" /> <img src="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_tight_crop_200.png" srcset="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_tight_crop_200.png 1x" width="200" height="74" alt="The Roman Catholic Archdiocese of Singapore Logo" data-retina_logo_url="" class="fusion-mobile-logo" /> <img src="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_no_wordings_65.png" srcset="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_no_wordings_65.png 1x, https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-114.png 2x" width="65" height="65" style="max-height:65px;height:auto;" alt="The Roman Catholic Archdiocese of Singapore Logo" data-retina_logo_url="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-114.png" class="fusion-sticky-logo" /> </a></div><div class="fusion-mobile-menu-icons"> <a href="#" class="fusion-icon fusion-icon-bars" aria-label="Toggle mobile menu" aria-expanded="false"></a> <a href="#" class="fusion-icon fusion-icon-search" aria-label="Toggle mobile search"></a></div></div></div><div class="fusion-secondary-main-menu"><div class="fusion-row"> <nav class="fusion-main-menu" aria-label="Main Menu"><ul id="menu-main-menu-v1-0" class="fusion-menu"><li id="menu-item-59777" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59777 fusion-dropdown-menu" data-item-id="59777"><a href="#" class="fusion-bar-highlight"><span class="menu-text">ABOUT</span></a><ul role="menu" class="sub-menu"><li id="menu-item-59778" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59778 fusion-dropdown-submenu"><a href="https://www.catholic.sg/about/" class="fusion-bar-highlight"><span>Our Archdiocese</span></a></li><li id="menu-item-59780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59780 fusion-dropdown-submenu"><a target="_blank" rel="noopener noreferrer" href="http://history.catholic.sg/" class="fusion-bar-highlight"><span>Our History</span></a></li><li id="menu-item-59781" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59781 fusion-dropdown-submenu"><a href="https://www.catholic.sg/our-channels/" class="fusion-bar-highlight"><span>Our Channels</span></a></li><li id="menu-item-65125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65125 fusion-dropdown-submenu"><a href="https://www.catholic.sg/notices/" class="fusion-bar-highlight"><span>Latest Notices &#038; Messages</span></a></li></ul></li><li id="menu-item-59720" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59720 fusion-dropdown-menu" data-item-id="59720"><a href="#" class="fusion-bar-highlight"><span class="menu-text">OUR FAITH</span></a><ul role="menu" class="sub-menu"><li id="menu-item-10928" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10928 fusion-dropdown-submenu"><a href="https://www.catholic.sg/our-faith/" class="fusion-bar-highlight"><span>Introduction</span></a></li><li id="menu-item-11973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11973 fusion-dropdown-submenu"><a href="https://www.catholic.sg/our-faith/catholic-stance-towards-non-christian-religions/" class="fusion-bar-highlight"><span>Catholic Stance Towards Non-Christian Religions</span></a></li><li id="menu-item-13624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13624 fusion-dropdown-submenu"><a href="https://www.catholic.sg/our-faith/declarationoffaith/" class="fusion-bar-highlight"><span>Declaration of Faith</span></a></li><li id="menu-item-10918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10918 fusion-dropdown-submenu"><a href="https://www.catholic.sg/our-faith/sacredscripture/" class="fusion-bar-highlight"><span>Sacred Scripture</span></a></li><li id="menu-item-50489" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-50489 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Liturgy</span></a><ul role="menu" class="sub-menu"><li id="menu-item-46147" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46147"><a href="https://www.catholic.sg/our-faith/liturgy/" class="fusion-bar-highlight"><span>Liturgical Policies</span></a></li><li id="menu-item-50490" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50490"><a href="https://www.catholic.sg/articles-liturgy/" class="fusion-bar-highlight"><span>Articles on Liturgy</span></a></li></ul></li><li id="menu-item-15822" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-15822 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Prayers</span></a><ul role="menu" class="sub-menu"><li id="menu-item-20017" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20017"><a href="/articles/a-meeting-of-hearts/" class="fusion-bar-highlight"><span>Why and How to Pray</span></a></li><li id="menu-item-16218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16218"><a href="https://www.catholic.sg/our-faith/thelordsprayer/" class="fusion-bar-highlight"><span>The Lord&#8217;s Prayer</span></a></li><li id="menu-item-15823" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15823"><a href="https://www.catholic.sg/our-faith/prayers/divine-office-lauds/" class="fusion-bar-highlight"><span>The Divine Office</span></a></li><li id="menu-item-18268" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18268"><a href="https://www.catholic.sg/our-faith/the-angelus/" class="fusion-bar-highlight"><span>The Angelus</span></a></li><li id="menu-item-43189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43189"><a href="https://www.catholic.sg/our-faith/prayerbook/" class="fusion-bar-highlight"><span>Our Prayer Book</span></a></li><li id="menu-item-15995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15995"><a href="https://www.catholic.sg/our-faith/otherprayers/" class="fusion-bar-highlight"><span>Other Prayers</span></a></li><li id="menu-item-10917" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10917"><a href="https://www.catholic.sg/our-faith/frequently-asked-questions/" class="fusion-bar-highlight"><span>FAQs About Faith</span></a></li></ul></li><li id="menu-item-59804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59804 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Resources</span></a><ul role="menu" class="sub-menu"><li id="menu-item-10916" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10916"><a href="https://www.catholic.sg/our-faith/resources/" class="fusion-bar-highlight"><span>Let&#8217;s Get Started!</span></a></li><li id="menu-item-12638" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12638"><a href="https://www.catholic.sg/our-faith/resources/knowing-the-faith/" class="fusion-bar-highlight"><span>Knowing the Faith</span></a></li><li id="menu-item-12639" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12639"><a href="https://www.catholic.sg/our-faith/resources/living-the-faith/" class="fusion-bar-highlight"><span>Living the Faith</span></a></li><li id="menu-item-21564" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21564"><a href="https://www.catholic.sg/our-faith/laudato-si-care-common-home/" class="fusion-bar-highlight"><span>Laudato Si&#8217;</span></a></li></ul></li></ul></li><li id="menu-item-59721" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59721 fusion-dropdown-menu" data-item-id="59721"><a href="#" class="fusion-bar-highlight"><span class="menu-text">PARTICIPATE</span></a><ul role="menu" class="sub-menu"><li id="menu-item-10964" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10964 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/" class="fusion-bar-highlight"><span>Introduction</span></a></li><li id="menu-item-60610" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60610 fusion-dropdown-submenu"><a href="https://www.catholic.sg/conversation/" class="fusion-bar-highlight"><span>CatholicSG Conversation</span></a></li><li id="menu-item-10962" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10962 fusion-dropdown-submenu"><a href="https://www.catholic.sg/becomingcatholic/" class="fusion-bar-highlight"><span>Becoming Catholic</span></a></li><li id="menu-item-10961" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10961 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/returning-catholics/" class="fusion-bar-highlight"><span>Returning Catholics</span></a></li><li id="menu-item-10960" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10960 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/new-evangelisation/" class="fusion-bar-highlight"><span>New Evangelisation</span></a></li><li id="menu-item-55947" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55947 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/share_rcia/" class="fusion-bar-highlight"><span>Share Our Faith</span></a></li><li id="menu-item-12130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12130 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/formation/" class="fusion-bar-highlight"><span>Faith Formation</span></a></li><li id="menu-item-10963" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10963 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/vocations/" class="fusion-bar-highlight"><span>Vocations</span></a></li><li id="menu-item-13518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13518 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/marriageandfamily/" class="fusion-bar-highlight"><span>Marriage &#038; Family</span></a></li><li id="menu-item-15671" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15671 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/youthandyoungadults/" class="fusion-bar-highlight"><span>Youths &#038; Young Adults</span></a></li><li id="menu-item-75931" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75931 fusion-dropdown-submenu"><a href="https://www.catholic.sg/activities-for-children/" class="fusion-bar-highlight"><span>Children</span></a></li><li id="menu-item-10959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10959 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/catholic-schools/" class="fusion-bar-highlight"><span>Catholic Schools</span></a></li><li id="menu-item-59805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59805 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Let Us Pray&#8230;</span></a><ul role="menu" class="sub-menu"><li id="menu-item-12869" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12869"><a href="https://www.catholic.sg/get-assistance/pray-for-someone/" class="fusion-bar-highlight"><span>Pray for Someone</span></a></li><li id="menu-item-43881" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43881"><a href="https://www.catholic.sg/our-faith/prayerbook/" class="fusion-bar-highlight"><span>My Prayer Book</span></a></li></ul></li><li id="menu-item-19431" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19431 fusion-dropdown-submenu"><a href="https://www.catholic.sg/proud2b-2/" class="fusion-bar-highlight"><span>#proud2bCatholic</span></a></li><li id="menu-item-22291" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22291 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/just-for-fun/" class="fusion-bar-highlight"><span>Just for Fun Quiz</span></a></li></ul></li><li id="menu-item-39462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39462 fusion-dropdown-menu" data-item-id="39462"><a href="#" class="fusion-bar-highlight"><span class="menu-text">ARTICLES</span></a><ul role="menu" class="sub-menu"><li id="menu-item-56264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56264 fusion-dropdown-submenu"><a target="_blank" rel="noopener noreferrer" href="https://stories.catholic.sg" class="fusion-bar-highlight"><span>Stories</span></a></li><li id="menu-item-56265" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56265 fusion-dropdown-submenu"><a href="https://www.catholic.sg/articles/" class="fusion-bar-highlight"><span>Reflections</span></a></li></ul></li><li id="menu-item-59722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59722 fusion-dropdown-menu" data-item-id="59722"><a href="#" class="fusion-bar-highlight"><span class="menu-text">EVENTS</span></a><ul role="menu" class="sub-menu"><li id="menu-item-12876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12876 fusion-dropdown-submenu"><a href="/events/" class="fusion-bar-highlight"><span>View Events</span></a></li><li id="menu-item-28925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-28925 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Publicise Event</span></a><ul role="menu" class="sub-menu"><li id="menu-item-28926" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28926"><a href="/events/announcement-advertisement-request/" class="fusion-bar-highlight"><span>Announcement &#038; Advertisement Request</span></a></li><li id="menu-item-28927" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28927"><a href="/events/publicise-event/" class="fusion-bar-highlight"><span>Event Submission Process</span></a></li></ul></li><li id="menu-item-13332" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13332 fusion-dropdown-submenu"><a href="https://www.catholic.sg/events/catholic-liturgical-calendar/" class="fusion-bar-highlight"><span>Catholic Liturgical Calendar</span></a></li><li id="menu-item-24850" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24850 fusion-dropdown-submenu"><a href="https://www.catholic.sg/events/confirmation-dates-2/" class="fusion-bar-highlight"><span>Confirmation Dates 2020</span></a></li><li id="menu-item-24851" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24851 fusion-dropdown-submenu"><a target="_blank" rel="noopener noreferrer" href="https://www.flickr.com/photos/catholicsg/albums" class="fusion-bar-highlight"><span>Event Photos</span></a></li><li id="menu-item-41035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41035 fusion-dropdown-submenu"><a href="https://www.catholic.sg/events/past-events/" class="fusion-bar-highlight"><span>Past Events &#038; Livestreams Archive</span></a></li></ul></li><li id="menu-item-59723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59723 fusion-dropdown-menu" data-item-id="59723"><a href="#" class="fusion-bar-highlight"><span class="menu-text">VISIT &#038; MASS</span></a><ul role="menu" class="sub-menu"><li id="menu-item-76577" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-76577 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Booking for Mass</span></a><ul role="menu" class="sub-menu"><li id="menu-item-76581" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76581"><a target="_blank" rel="noopener noreferrer" href="https://mycatholic.sg/faq" class="fusion-bar-highlight"><span>FAQ on registration &#038; booking of Mass</span></a></li><li id="menu-item-76578" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76578"><a target="_blank" rel="noopener noreferrer" href="https://mycatholic.sg/register" class="fusion-bar-highlight"><span>Register at myCatholic.sg</span></a></li><li id="menu-item-76580" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76580"><a target="_blank" rel="noopener noreferrer" href="https://mycatholic.sg/schedule" class="fusion-bar-highlight"><span>Check Mass booking schedule</span></a></li><li id="menu-item-76579" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76579"><a target="_blank" rel="noopener noreferrer" href="https://mycatholic.sg/login" class="fusion-bar-highlight"><span>Book your Mass</span></a></li><li id="menu-item-76582" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76582"><a target="_blank" rel="noopener noreferrer" href="https://mycatholic.sg/help" class="fusion-bar-highlight"><span>Help on registration &#038; Mass booking</span></a></li></ul></li><li id="menu-item-26500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26500 fusion-dropdown-submenu"><a href="https://www.catholic.sg/visit-mass/" class="fusion-bar-highlight"><span>Introduction</span></a></li><li id="menu-item-47694" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47694 fusion-dropdown-submenu"><a href="https://www.catholic.sg/visit-mass/livestream/" class="fusion-bar-highlight"><span>Livestream</span></a></li><li id="menu-item-24836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24836 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/find_mass/" class="fusion-bar-highlight"><span>Find A Mass</span></a></li><li id="menu-item-40449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40449 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/singapore-mass-schedule-catholic/" class="fusion-bar-highlight"><span>Mass Schedules</span></a></li><li id="menu-item-24837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24837 fusion-dropdown-submenu"><a href="https://www.catholic.sg/mass-readings/" class="fusion-bar-highlight"><span>Mass Readings</span></a></li><li id="menu-item-24838" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24838 fusion-dropdown-submenu"><a href="https://www.catholic.sg/visit-mass/the-order-of-mass/" class="fusion-bar-highlight"><span>The Order Of Mass</span></a></li><li id="menu-item-24852" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24852 fusion-dropdown-submenu"><a href="https://www.catholic.sg/visit-mass/days-of-obligation/" class="fusion-bar-highlight"><span>Days of Obligation &#038; Important Services</span></a></li><li id="menu-item-64226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64226 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/find_service/" class="fusion-bar-highlight"><span>Prayers, Devotions, &#038; Services</span></a></li><li id="menu-item-24854" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24854 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/go-for-confession/" class="fusion-bar-highlight"><span>Go for Confession</span></a></li></ul></li><li id="menu-item-59724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59724 fusion-dropdown-menu" data-item-id="59724"><a href="#" class="fusion-bar-highlight"><span class="menu-text">GET ASSISTANCE</span></a><ul role="menu" class="sub-menu"><li id="menu-item-24840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24840 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/" class="fusion-bar-highlight"><span>Social Services</span></a></li><li id="menu-item-70591" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-70591 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>COVID-19</span></a><ul role="menu" class="sub-menu"><li id="menu-item-68985" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68985"><a href="https://www.catholic.sg/coronavirus/" class="fusion-bar-highlight"><span>Updates &#038; Guidelines</span></a></li><li id="menu-item-76792" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76792"><a href="https://www.catholic.sg/faqs-on-resumption-of-mass-on-phase-ii/" class="fusion-bar-highlight"><span>FAQs: Resumption of Masses (Updated as of 8 Oct 2020)</span></a></li><li id="menu-item-71075" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71075"><a href="https://www.catholic.sg/offertory/" class="fusion-bar-highlight"><span>Church Donation</span></a></li><li id="menu-item-70595" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70595"><a href="https://www.catholic.sg/catholics-countering-covid-19/" class="fusion-bar-highlight"><span>Reflection Series</span></a></li><li id="menu-item-72319" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72319"><a href="https://www.catholic.sg/ministeringonline/" class="fusion-bar-highlight"><span>Ministering online through COVID-19</span></a></li></ul></li><li id="menu-item-44444" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44444 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/hospital-pastoral-care/" class="fusion-bar-highlight"><span>Hospital Pastoral Care</span></a></li><li id="menu-item-24842" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24842 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/prayer-requests/" class="fusion-bar-highlight"><span>Ask for Prayers</span></a></li><li id="menu-item-40440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40440 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/programmes-by-catholic-church/" class="fusion-bar-highlight"><span>Programmes Provided</span></a></li><li id="menu-item-43719" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43719 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/support-services-by-catholic-church-in-singapore/" class="fusion-bar-highlight"><span>Support Services Provided</span></a></li><li id="menu-item-41718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41718 fusion-dropdown-submenu"><a href="https://www.catholic.sg/countering-fake-news/" class="fusion-bar-highlight"><span>Countering Fake News</span></a></li><li id="menu-item-51158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51158 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/report-an-incident/" class="fusion-bar-highlight"><span>Report an Incident</span></a></li><li id="menu-item-59806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59806 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Chancery Service</span></a><ul role="menu" class="sub-menu"><li id="menu-item-28211" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28211"><a href="http://chancery.catholic.sg/" class="fusion-bar-highlight"><span>About The Chancery</span></a></li><li id="menu-item-28216" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28216"><a href="https://chancery.catholic.sg/change-of-details/" class="fusion-bar-highlight"><span>Change Parish or Organisation Details</span></a></li><li id="menu-item-28212" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28212"><a href="https://chancery.catholic.sg/statement-suitability-ministry/" class="fusion-bar-highlight"><span>Statement of Suitability for Ministry</span></a></li><li id="menu-item-28214" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28214"><a href="https://chancery.catholic.sg/conflict-resolution-2/" class="fusion-bar-highlight"><span>Conflict Resolution Process</span></a></li><li id="menu-item-28215" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28215"><a href="https://chancery.catholic.sg/terms-parish-columbaria/" class="fusion-bar-highlight"><span>Terms for Parish Columbaria</span></a></li></ul></li><li id="menu-item-59807" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59807 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Communication Services</span></a><ul role="menu" class="sub-menu"><li id="menu-item-35950" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35950"><a href="https://archcomms.catholic.sg/" class="fusion-bar-highlight"><span>ArchComms</span></a></li><li id="menu-item-35951" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35951"><a href="https://archcomms.catholic.sg/policies-guidelines/" class="fusion-bar-highlight"><span>Policies, Guidelines &#038; Copyright</span></a></li><li id="menu-item-35952" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35952"><a href="https://archcomms.catholic.sg/resources/" class="fusion-bar-highlight"><span>Other Resources</span></a></li><li id="menu-item-35953" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35953"><a href="https://archcomms.catholic.sg/request/" class="fusion-bar-highlight"><span>Request for Account</span></a></li></ul></li><li id="menu-item-44705" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44705 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/organisation-contact-details-information/?gr3ApI=502" class="fusion-bar-highlight"><span>Professional Standards Office</span></a></li><li id="menu-item-24845" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24845 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/search-support-services-singapore-catholic-church/" class="fusion-bar-highlight"><span>Other Support Services</span></a></li><li id="menu-item-24846" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24846 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/getassistance-faqs/" class="fusion-bar-highlight"><span>Frequently Asked Questions</span></a></li></ul></li><li id="menu-item-26814" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-26814 fusion-dropdown-menu" data-item-id="26814"><a href="#" class="fusion-bar-highlight"><span class="menu-text">DIRECTORY</span></a><ul role="menu" class="sub-menu"><li id="menu-item-24982" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24982 fusion-dropdown-submenu"><a href="/directory/singapore_catholic_church/" class="fusion-bar-highlight"><span>Church Directory</span></a></li><li id="menu-item-24983" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24983 fusion-dropdown-submenu"><a href="/directory/singapore_catholic_church/parish/" class="fusion-bar-highlight"><span>Parish Information</span></a></li><li id="menu-item-24848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24848 fusion-dropdown-submenu"><a href="https://www.catholic.sg/visit-mass/map-of-churches/" class="fusion-bar-highlight"><span>Map of Churches</span></a></li><li id="menu-item-26717" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26717 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/chapel-prayer-halls/" class="fusion-bar-highlight"><span>Chapel &#038; Prayer Halls</span></a></li><li id="menu-item-24857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24857 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/priest_clergy/" class="fusion-bar-highlight"><span>Priest / Clergy Listing</span></a></li><li id="menu-item-24859" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24859 fusion-dropdown-submenu"><a href="/directory/singapore_catholic_church/organisation-details/?G1ZTpe=Communities" class="fusion-bar-highlight"><span>Religious</span></a></li><li id="menu-item-24858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24858 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/sacerdotal_anniversaries/" class="fusion-bar-highlight"><span>Sacerdotal Anniversaries</span></a></li></ul></li><li id="menu-item-59725" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59725 fusion-dropdown-menu" data-item-id="59725"><a href="#" class="fusion-bar-highlight"><span class="menu-text">ARCHBISHOP</span></a><ul role="menu" class="sub-menu"><li id="menu-item-24889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24889 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/" class="fusion-bar-highlight"><span>Introduction</span></a></li><li id="menu-item-24885" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24885 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/about/" class="fusion-bar-highlight"><span>About</span></a></li><li id="menu-item-33602" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33602 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/from-vision-to-reality/" class="fusion-bar-highlight"><span>From Vision to Reality</span></a></li><li id="menu-item-24888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24888 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/scripture-reflection/" class="fusion-bar-highlight"><span>Daily Scripture Reflection</span></a></li><li id="menu-item-24878" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24878 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/pastoral-letters/" class="fusion-bar-highlight"><span>Pastoral Letters</span></a></li><li id="menu-item-24877" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24877 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/votive-homilies/" class="fusion-bar-highlight"><span>Votive Homilies</span></a></li><li id="menu-item-59811" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59811 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>His Messages</span></a><ul role="menu" class="sub-menu"><li id="menu-item-24882" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24882"><a href="https://www.catholic.sg/archbishop/his-messages/current-events/" class="fusion-bar-highlight"><span>Current Events</span></a></li><li id="menu-item-24883" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24883"><a href="https://www.catholic.sg/archbishop/his-messages/catholic-occasions/" class="fusion-bar-highlight"><span>Catholic Occasions</span></a></li><li id="menu-item-24881" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24881"><a href="https://www.catholic.sg/archbishop/his-messages/other-occasions/" class="fusion-bar-highlight"><span>Other Occasions</span></a></li></ul></li><li id="menu-item-24884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24884 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/his-messages/speeches/" class="fusion-bar-highlight"><span>Speeches</span></a></li><li id="menu-item-24879" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24879 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/announcements-news/" class="fusion-bar-highlight"><span>Archbishop News</span></a></li><li id="menu-item-24887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24887 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/video-gallery/" class="fusion-bar-highlight"><span>Video Gallery</span></a></li><li id="menu-item-24876" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24876 fusion-dropdown-submenu"><a target="_blank" rel="noopener noreferrer" href="https://www.catholic.sg/archbishop/cathedralofthegoodshepherd/" class="fusion-bar-highlight"><span>Cathedral of the Good Shepherd</span></a></li></ul></li><li id="menu-item-59782" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59782 fusion-dropdown-menu" data-item-id="59782"><a href="#" class="fusion-bar-highlight"><span class="menu-text">CONTACT</span></a><ul role="menu" class="sub-menu"><li id="menu-item-59783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59783 fusion-dropdown-submenu"><a href="https://www.catholic.sg/contact/general/" class="fusion-bar-highlight"><span>General Enquiry</span></a></li><li id="menu-item-59784" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59784 fusion-dropdown-submenu"><a href="https://www.catholic.sg/contact/events/" class="fusion-bar-highlight"><span>Events Calendar Enquiry</span></a></li><li id="menu-item-59785" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59785 fusion-dropdown-submenu"><a href="https://www.catholic.sg/contact/directory/" class="fusion-bar-highlight"><span>Church Directory Enquiry</span></a></li><li id="menu-item-59786" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59786 fusion-dropdown-submenu"><a href="https://archcomms.catholic.sg/contact/?gr3ApI=513" class="fusion-bar-highlight"><span>Media Contact</span></a></li><li id="menu-item-59787" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59787 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/prayer-requests/" class="fusion-bar-highlight"><span>Prayer Requests Submissions</span></a></li><li id="menu-item-59788" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59788 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/" class="fusion-bar-highlight"><span>Parishes/Organisations Contact</span></a></li><li id="menu-item-100737" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-100737 fusion-dropdown-submenu"><a href="https://www.catholic.sg/donate/" class="fusion-bar-highlight"><span>Give</span></a></li></ul></li><li class="fusion-custom-menu-item fusion-main-menu-search"><a class="fusion-main-menu-icon fusion-bar-highlight" href="#" aria-label="Search" data-title="Search" title="Search"></a><div class="fusion-custom-menu-item-contents"><form role="search" class="searchform fusion-search-form fusion-live-search" method="get" action="https://www.catholic.sg/"><div class="fusion-search-form-content"><div class="fusion-search-field search-field"> <label><span class="screen-reader-text">Search for:</span> <input type="search" value="" name="s" class="s" placeholder="Search ..." required aria-required="true" aria-label="Search ..." /> </label></div><div class="fusion-search-button search-button"> <input type="submit" class="fusion-search-submit searchsubmit" value="&#xf002;" /></div></div></form></div></li></ul></nav> <nav class="fusion-mobile-nav-holder fusion-mobile-menu-text-align-left" aria-label="Main Menu Mobile"></nav><div class="fusion-clearfix"></div><div class="fusion-mobile-menu-search"><form role="search" class="searchform fusion-search-form fusion-live-search" method="get" action="https://www.catholic.sg/"><div class="fusion-search-form-content"><div class="fusion-search-field search-field"> <label><span class="screen-reader-text">Search for:</span> <input type="search" value="" name="s" class="s" placeholder="Search ..." required aria-required="true" aria-label="Search ..." /> </label></div><div class="fusion-search-button search-button"> <input type="submit" class="fusion-search-submit searchsubmit" value="&#xf002;" /></div></div></form></div></div></div></div></div><div class="fusion-clearfix"></div> </header><div id="sliders-container"></div><div class="avada-page-titlebar-wrapper"></div><main id="main" class="clearfix "><div class="fusion-row" style=""><section id="content" style="width: 100%;"> <article id="post-123194" class="post post-123194 type-post status-publish format-standard has-post-thumbnail hentry category-scripture-reflection"><h1 class="entry-title fusion-post-title">13 November, 2020, Friday, 32nd Week, Ordinary Time</h1><div class="post-content"><div class="fusion-fullwidth fullwidth-box fusion-builder-row-1 hundred-percent-fullwidth non-hundred-percent-height-scrolling" style='background-color: rgba(255,255,255,0);background-position: center center;background-repeat: no-repeat;'><div class="fusion-builder-row fusion-row "><div class="fusion-layout-column fusion_builder_column fusion_builder_column_1_1 fusion-builder-column-1 fusion-one-full fusion-column-first fusion-column-last fusion-column-no-min-height 1_1" style='margin-top:0px;margin-bottom:0px;'><div class="fusion-column-wrapper" style="padding: 0px 0px 0px 0px;background-position:left top;background-repeat:no-repeat;-webkit-background-size:cover;-moz-background-size:cover;-o-background-size:cover;background-size:cover;" data-bg-url=""><div class="fusion-column-content-centered"><div class="fusion-column-content"><style type="text/css"></style><div class="fusion-title title fusion-title-1 fusion-sep-none fusion-title-text fusion-title-size-one" style="margin-top:20px;margin-bottom:20px;"><h1 class="title-heading-left" style="margin:0;">LIVING IN TRUTH AND LOVE</h1></div><div class="fusion-text"><hr /><p>SCRIPTURE READINGS: [2 JOHN 4-9; LUKE 17:26-37 ]</p></div><div class="fusion-text"><p style="text-align: justify"><strong>In the first reading, St John underscores the importance of walking in the truth.  </strong>What does it mean to walk in the truth?  It entails knowing the truth and walking in love.  In John&#8217;s understanding, walking in the truth presupposes that we know and believe in the full humanity of our Lord.  Only when we believe in the incarnation, can we imitate Him in love and service for God and our fellowmen.   The way to love is determined by our beliefs.  Truth and love are two faces of the same coin.  We can only love in truth.  Conversely, the only truth is love.   What, then, is truth?</p><p style="text-align: justify"><strong>Truth has a threefold dimension, doctrinal, moral and practical.  The latter aspect of truth and morality is love in action.  </strong>The danger is that in the world today, many want to love without truth.  Love has become an emotional word, a nice sentiment, a good feeling.   Worst still, love is reduced to a sensual pleasure, of sex, fun, merry-making, drinking and carousing.  It is a love without sacrifice, without responsibility, without commitment, without truth.  So, a couple cohabits and when they get tired of each other, since feelings do not always last, they will then separate.  Love has no permanence.  So long as both feel good with each other, they are supposedly to be in love.  That is why, today, couples change partners regularly, sometimes having a few partners at the same time.</p><p style="text-align: justify"><strong>Indeed, the word &#8220;love&#8221; is so ambiguous that we are confused as to the real meaning of love.  Every action is done in the name of love.</strong>  Those who advocate same-sex union do so in the name of love.  Why should we prevent two persons, regardless of gender, who are in love to express their love in a physical manner, including sexually?  The truth is that we all need physical love.  In the same vein, men and women in a relationship have no qualms about cohabiting in the name of love.  Even casual sexual relationships have become a way of life among many people to express love.  In the name of love, we also practice abortion so that they baby would not suffer without the love of the parents; or the parents would not suffer because of an unwanted pregnancy.  In the name of love too, we promote IVF and surrogate motherhood, because marriage is not complete without children. With a child, it could make the marriage richer and more fulfilling.  So, too, in the name of love, we promote euthanasia so that those who are old, mentally or physically challenged, suffering in life need not prolong their pain.  Finally, in the name of love, we allow divorce and remarriage, after all we do make mistakes in life and relationships sometimes do not turn out well.  It would be better to divorce so that the couple could find new relationships and happiness in life.</p><p style="text-align: justify"><strong>Indeed, such arguments are not without some basis.  But they are often deceptive and confusing.  </strong>Perhaps there are some elements of love involved in all the situations just mentioned.  The question is, whether this love is really love in the fullest sense of the term.  In other words, is this love founded on truth.  Surely, none of us want to be loved half-way or with a superficial love.   If love is true, it must be genuine, sincere and committed.  Who wants a love that lacks commitment and sincerity?  At any rate, is the person truly loving another, or loving himself or herself more?  The latter would be a self-centered love, making use of another to find one&#8217;s satisfaction or fulfillment.  If love is true, then it must always be self-sacrificial and selfless in giving.  It must be a love of the other, self and the community.</p><p style="text-align: justify"><strong>The question that is difficult to answer and poses a dilemma is, how we can be so sure we know the truth?</strong>  Everyone today claims to have the truth.  There are so many churches and many religions.  We all see truth so differently and from different perspectives.  Even the bible, the Word of God, has many different interpretations.   Theologians offer us many contradictory explanations of the Word of God.   We are in danger of moral relativism.</p><p style="text-align: justify"><strong>This is why the Church is called to provide moral guidance to the world on the way to love in truth.</strong>  The Christian&#8217;s claim of having the truth rests on her belief in Jesus as the revelation of God and the Holy Spirit that enlightens Him.  He is the Way, the Truth and the Life.  (cf Jn 14:6) He is the light of the world. Jesus said, &#8220;Whoever follows me will never walk in darkness but will have the light of life.&#8221; (Jn 8:12) He is the Word of God made man. St John wrote, &#8220;the Word became flesh and lived among us, and we have seen his glory, the glory as of a father&#8217;s only son, full of grace and truth.&#8221;  (Jn 1:14) Truth is therefore revealed by God and not simply a human construct.</p><p style="text-align: justify"><strong>In the final analysis, Christian love must be founded on truth.  This truth is incarnated in Jesus.  </strong>St John underscores the importance of affirming the true and full humanity of our Lord.  &#8220;There are many deceivers about in the world, refusing to admit that Jesus Christ had come in the flesh.  They are the Deceiver; they are the Antichrist.  Watch yourselves, or all our work will be lost and not get the reward it deserves.&#8221;  By confessing that Jesus is the Christ, truly God and man, one is confident as to how one should live one&#8217;s life in obedience to God&#8217;s love.  Jesus as the Son of God shows us the way to live our life in service to God. For this reason, St John declared, &#8220;If anybody does not keep within the teaching of Christ but goes beyond it, he cannot have God with him: only those who keep to what he taught can have the Father and the Son with them.&#8221;   In the gospel, Jesus made it clear &#8220;the kingdom of God is among you.&#8221;  (Lk 17:20f) The signs will be present in the way we live our lives.</p><p style="text-align: justify"><strong>Yet, the Church&#8217;s claim of having the truth remains contentious. </strong> It is a difficult claim since truth has many facets.  Whilst the Church is tolerant of different views, yet it is the Church&#8217;s responsibility to teach the truth in love.  The Church as the pillar and bulwark of truth must safeguard that doctrines and morality are in line with the revelation of scripture.  (cf 1 Tim 3:15) Whilst we can admit some degree of tolerance in theological plurality, yet, a line must be drawn with respect to doctrines.  Otherwise, the Church cannot safeguard the truth and it only leads to confusion.</p><p style="text-align: justify"><strong>Hence, the Church must always speak the truth in love.</strong>  The truth is proclaimed not to put people down or to make life miserable for them, but it is done out of love.  The danger of the Church today is that because of the fear of offending people who do not agree with us, we do not speak the truth because we lack sincere love for our people, only a love for oneself.  Failing to speak the truth is to do a disservice to our people.  Difficult as it may be, unwelcoming it may be to the world, yet the truth must be spoken lest we be held responsible by God for the sins of our people. (cf Ez 3:16-21) The Church as the watchman for society cannot neglect her role as moral spokesman.</p><p style="text-align: justify"><strong>This does not mean that the Church is imposing her beliefs on others.  The Church enters into dialogue with others who are seeking the truth. </strong> What is critical is that we seek the entire truth of the matter, not just a partial truth and answer to a moral question.  A moral issue has many perspectives, not just a personal matter but it has implications for the wider society as well.  What we do is not just our personal matter but the way we act will have an impact on the lives of others.  Whether it is marriage, divorce, same-sex union, abortion, euthanasia, IVF, etc, all these will have implications for society.  True love cannot be just limited between two persons as their actions will not impact the lives of those people around them or those that come after them.  In determining a moral position, we must be able to show that it is love in the beginning, middle and in the end.  It is a love that encompasses the two parties, their loved ones and God.  We cannot speak of love between two persons or love of self without thinking of those who will be impacted by our relationships.</p><p style="text-align: justify"><strong>Such a discussion normally is based on natural laws and where we are agreeable, we need to refer to the theological foundations for moral doctrines based on revelation. </strong> Ultimately, we are called to protect the dignity of the human person created in God&#8217;s image and likeness, who is invited to love and share in His life by dying for others selflessly.</p></div></div></div><div class="fusion-clearfix"></div></div></div><div class="fusion-layout-column fusion_builder_column fusion_builder_column_1_1 fusion-builder-column-2 fusion-one-full fusion-column-first fusion-column-last 1_1" style='margin-top:0px;margin-bottom:20px;'><div class="fusion-column-wrapper" style="padding: 0px 0px 0px 0px;background-position:left top;background-repeat:no-repeat;-webkit-background-size:cover;-moz-background-size:cover;-o-background-size:cover;background-size:cover;" data-bg-url=""><div class="fusion-text"><hr /><p><span style="font-size: 10pt">Written by The Most Rev William Goh, Roman Catholic Archbishop of Singapore &copy; All Rights Reserved. The contents of this page may not be reproduced, in whole or in part, in any form or by any means, without the prior written permission from the Archbishop&#8217;s Office. This includes extracts, quotations, and summaries.</span></p><hr /></div><div class="fusion-clearfix"></div></div></div><div class="fusion-layout-column fusion_builder_column fusion_builder_column_1_1 fusion-builder-column-3 fusion-one-full fusion-column-first fusion-column-last fusion-column-no-min-height 1_1" style='margin-top:20px;margin-bottom:20px;'><div class="fusion-column-wrapper" style="background-color:#e3f1f4;padding: 20px 20px 20px 20px;background-position:left top;background-repeat:no-repeat;-webkit-background-size:cover;-moz-background-size:cover;-o-background-size:cover;background-size:cover;" data-bg-url=""><style type="text/css"></style><div class="fusion-title title fusion-title-2 fusion-sep-none fusion-title-text fusion-title-size-five" style="margin-top:0px;margin-bottom:0px;"><h5 class="title-heading-left" style="margin:0;">Best Practices for Using the Daily Scripture Reflections</h5></div><div class="fusion-text"><ul><li><span style="font-size: 8pt"><em>Encounter God through the spirit of prayer and the scripture by reflecting and praying the Word of God daily. The purpose is to bring you to prayer and to a deeper union with the Lord on the level of the heart.</em></span></li><li><span style="font-size: 8pt"><em>Daily reflections when archived will lead many to accumulate all the reflections of the week and pray in one sitting. This will compromise your capacity to enter deeply into the Word of God, as the tendency is to read for knowledge rather than a prayerful reading of the Word for the purpose of developing a personal and affective relationship with the Lord.</em></span></li><li><span style="font-size: 8pt"><em>It is more important to pray deeply, not read widely. The current reflections of the day would be more than sufficient for anyone who wants to pray deeply and be led into an intimacy with the Lord.</em></span></li></ul><p><span style="font-size: 8pt"><em>Note: You may share this reflection with someone. However, please note that reflections are not archived online nor will they be available via email request.</em></span></p></div><div class="fusion-clearfix"></div></div></div></div></div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="addtoany_header">Share This!</div><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.catholic.sg/13-november-2020-friday-32nd-week-ordinary-time/" data-a2a-title="13 November, 2020, Friday, 32nd Week, Ordinary Time"><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fwww.catholic.sg%2F13-november-2020-friday-32nd-week-ordinary-time%2F&amp;linkname=13%20November%2C%202020%2C%20Friday%2C%2032nd%20Week%2C%20Ordinary%20Time" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.catholic.sg%2F13-november-2020-friday-32nd-week-ordinary-time%2F&amp;linkname=13%20November%2C%202020%2C%20Friday%2C%2032nd%20Week%2C%20Ordinary%20Time" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_messenger" href="https://www.addtoany.com/add_to/facebook_messenger?linkurl=https%3A%2F%2Fwww.catholic.sg%2F13-november-2020-friday-32nd-week-ordinary-time%2F&amp;linkname=13%20November%2C%202020%2C%20Friday%2C%2032nd%20Week%2C%20Ordinary%20Time" title="Facebook Messenger" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_google_gmail" href="https://www.addtoany.com/add_to/google_gmail?linkurl=https%3A%2F%2Fwww.catholic.sg%2F13-november-2020-friday-32nd-week-ordinary-time%2F&amp;linkname=13%20November%2C%202020%2C%20Friday%2C%2032nd%20Week%2C%20Ordinary%20Time" title="Gmail" rel="nofollow noopener" target="_blank"></a></div></div></div><span class="vcard rich-snippet-hidden"><span class="fn"><a href="https://www.catholic.sg/author/trcas-pa/" title="Posts by Magdalene Lee" rel="author">Magdalene Lee</a></span></span><span class="updated rich-snippet-hidden">2020-11-13T01:14:51+08:00</span> </article> </section></div> </main><div class="fusion-footer fusion-footer-parallax"> <footer class="fusion-footer-widget-area fusion-widget-area"><div class="fusion-row"><div class="fusion-columns fusion-columns-3 fusion-widget-area"><div class="fusion-column col-lg-4 col-md-4 col-sm-4"><style type="text/css" data-id="nav_menu-48">@media (max-width: 800px){#nav_menu-48{text-align:initial !important}}</style><section id="nav_menu-48" class="fusion-widget-mobile-align-initial fusion-widget-align-left fusion-footer-widget-column widget widget_nav_menu" style="text-align: left;"><h4 class="widget-title">Admin Links</h4><div class="menu-footer-left-container"><ul id="menu-footer-left" class="menu"><li id="menu-item-59871" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59871"><a target="_blank" rel="noopener noreferrer" href="http://intranet.catholic.sg/">Archdiocese Intranet</a></li><li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://www.catholic.sg/login/">Website Login</a></li><li id="menu-item-59873" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59873"><a href="https://www.catholic.sg/pdpa-policy/">Archdiocese PDPA Policy</a></li><li id="menu-item-59874" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59874"><a href="https://www.catholic.sg/terms/">Terms &#038; Conditions</a></li></ul></div><div style="clear:both;"></div></section></div><div class="fusion-column col-lg-4 col-md-4 col-sm-4"><style type="text/css" data-id="nav_menu-49">@media (max-width: 800px){#nav_menu-49{text-align:initial !important}}</style><section id="nav_menu-49" class="fusion-widget-mobile-align-initial fusion-widget-align-center fusion-footer-widget-column widget widget_nav_menu" style="padding: 0px;text-align: center;"><h4 class="widget-title">Vibrant, Evangelising, &#038; Missionary Church</h4><div class="menu-footer-centre-container"><ul id="menu-footer-centre" class="menu"><li id="menu-item-59875" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59875"><a href="https://www.catholic.sg/offertory-2">Donate Now</a></li><li id="menu-item-59876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59876"><a href="https://www.catholic.sg/seek-opportunities/">Work &#038; Volunteer Opportunities</a></li><li id="menu-item-76872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76872"><a target="_blank" rel="noopener noreferrer" href="https://www.catholicfoundation.sg/give"><center><a href="https://www.catholicfoundation.sg/give" target="_blank" rel="noopener noreferrer"> <img src="https://www.catholic.sg/wp-content/uploads/2020/07/GIFT_bw.png" alt="GIFT" width="100" height="99"></a></center></a></li></ul></div><div style="clear:both;"></div></section></div><div class="fusion-column fusion-column-last col-lg-4 col-md-4 col-sm-4"><style type="text/css" data-id="nav_menu-51">@media (max-width: 800px){#nav_menu-51{text-align:initial !important}}</style><section id="nav_menu-51" class="fusion-widget-mobile-align-initial fusion-widget-align-right fusion-footer-widget-column widget widget_nav_menu" style="text-align: right;"><h4 class="widget-title">Archdiocese Media</h4><div class="menu-footer-right-container"><ul id="menu-footer-right" class="menu"><li id="menu-item-59885" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59885"><a href="https://www.catholic.sg/participate/bulletin/">Archdiocese eBulletin</a></li><li id="menu-item-59886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59886"><a target="_blank" rel="noopener noreferrer" href="https://catholicnews.sg/">Catholic News</a></li><li id="menu-item-59887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59887"><a href="https://radio.catholic.sg">Catholic Radio</a></li><li id="menu-item-59888" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59888"><a href="https://www.catholic.sg/our-channels/">Social Media</a></li></ul></div><div style="clear:both;"></div></section></div><div class="fusion-clearfix"></div></div></div> </footer> <footer id="footer" class="fusion-footer-copyright-area"><div class="fusion-row"><div class="fusion-copyright-content"><div class="fusion-copyright-notice"><div> © 2014-2020 Roman Catholic Archdiocese of Singapore.  All Rights Reserved.</div></div><div class="fusion-social-links-footer"><div class="fusion-social-networks"><div class="fusion-social-networks-wrapper"><a class="fusion-social-network-icon fusion-tooltip fusion-facebook fusion-icon-facebook" style href="https://www.facebook.com/Catholic.Sg" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="Facebook" data-toggle="tooltip" title="Facebook"><span class="screen-reader-text">Facebook</span></a><a class="fusion-social-network-icon fusion-tooltip fusion-twitter fusion-icon-twitter" style href="https://twitter.com/catholicssg" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="Twitter" data-toggle="tooltip" title="Twitter"><span class="screen-reader-text">Twitter</span></a><a class="fusion-social-network-icon fusion-tooltip fusion-instagram fusion-icon-instagram" style href="https://instagram.com/catholic.sg/" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="Instagram" data-toggle="tooltip" title="Instagram"><span class="screen-reader-text">Instagram</span></a><a class="fusion-social-network-icon fusion-tooltip fusion-youtube fusion-icon-youtube" style href="https://www.youtube.com/user/CatholicsSg" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="YouTube" data-toggle="tooltip" title="YouTube"><span class="screen-reader-text">YouTube</span></a><a class="fusion-social-network-icon fusion-tooltip fusion-vimeo fusion-icon-vimeo" style href="https://vimeo.com/catholicsg" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="Vimeo" data-toggle="tooltip" title="Vimeo"><span class="screen-reader-text">Vimeo</span></a><a class="fusion-social-network-icon fusion-tooltip fusion-flickr fusion-icon-flickr fusion-last-social-icon" style href="https://www.flickr.com/photos/catholicsg/albums" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="Flickr" data-toggle="tooltip" title="Flickr"><span class="screen-reader-text">Flickr</span></a><a class="fusion-social-network-icon fusion-tooltip fusion-linkedin fusion-icon-linkedin" style href="https://www.linkedin.com/company/catholicsg" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="LinkedIn" data-toggle="tooltip" title="LinkedIn"><span class="screen-reader-text">LinkedIn</span></a><a class="custom fusion-social-network-icon fusion-tooltip fusion-custom fusion-icon-custom" style="position:relative;" href="https://www.catholic.sg/install-telegram/" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="Telegram" data-toggle="tooltip" title="Telegram"><span class="screen-reader-text">Telegram</span><img src="https://www.catholic.sg/wp-content/uploads/2019/07/telegram_grey.png" style="width:auto;" alt="Telegram" /></a><a class="custom fusion-social-network-icon fusion-tooltip fusion-custom fusion-icon-custom" style="position:relative;" href="https://www.catholic.sg/radio/" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="CatholicSG Radio" data-toggle="tooltip" title="CatholicSG Radio"><span class="screen-reader-text">CatholicSG Radio</span><img src="https://www.catholic.sg/wp-content/uploads/2019/07/CSG_radio.png" style="width:auto;" alt="CatholicSG Radio" /></a><a class="custom fusion-social-network-icon fusion-tooltip fusion-custom fusion-icon-custom" style="position:relative;" href="https://app.catholic.sg/" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="CatholicSG App" data-toggle="tooltip" title="CatholicSG App"><span class="screen-reader-text">CatholicSG App</span><img src="https://www.catholic.sg/wp-content/uploads/2019/07/catholicSG_grey.png" style="width:auto;" alt="CatholicSG App" /></a></div></div></div></div></div> </footer></div><div class="fusion-sliding-bar-wrapper"></div></div></div><div class="fusion-top-frame"></div><div class="fusion-bottom-frame"></div><div class="fusion-boxed-shadow"></div> <a class="fusion-one-page-text-link fusion-page-load-link"></a><div class="avada-footer-scripts"><style>.comment-form-url,#url{display:none}</style><style>.comment-form-email,#email{display:none}</style><script>var refTagger={settings:{bibleVersion:"RSVCE",libronixBibleVersion:"RSVCE",addLogosLink:false,appendIconToLibLinks:false,libronixLinkIcon:"dark",noSearchClassNames:[],useTooltip:true,noSearchTagNames:["h1","h2","h3"],linksOpenNewWindow:true,convertHyperlinks:false,caseInsensitive:true,tagChapters:true}};(function(d,t){var g=d.createElement(t),s=d.getElementsByTagName(t)[0];g.src='//api.reftagger.com/v2/reftagger.js';s.parentNode.insertBefore(g,s);}(document,'script'));</script> <script>(function(body){'use strict';body.className=body.className.replace(/\btribe-no-js\b/,'tribe-js');})(document.body);</script> <script type="text/javascript">var recaptcha_widgets={};function wp_recaptchaLoadCallback(){try{grecaptcha;}catch(err){return;}
var e=document.querySelectorAll?document.querySelectorAll('.g-recaptcha:not(.wpcf7-form-control)'):document.getElementsByClassName('g-recaptcha'),form_submits;for(var i=0;i<e.length;i++){(function(el){var wid;if(!el.childNodes.length){wid=grecaptcha.render(el,{'sitekey':'6Lcu8gETAAAAAOV74Tc_XObQffW4HYlhErAPrA_D','theme':el.getAttribute('data-theme')||'light'});el.setAttribute('data-widget-id',wid);}else{wid=el.getAttribute('data-widget-id');grecaptcha.reset(wid);}})(e[i]);}}
if(typeof jQuery!=='undefined')
jQuery(document).ajaxComplete(function(evt,xhr,set){if(xhr.responseText&&xhr.responseText.indexOf('6Lcu8gETAAAAAOV74Tc_XObQffW4HYlhErAPrA_D')!==-1)
wp_recaptchaLoadCallback();});</script><script src="https://www.google.com/recaptcha/api.js?onload=wp_recaptchaLoadCallback&#038;render=explicit" async defer></script> <script>var tribe_l10n_datatables={"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js'></script><script type='text/javascript'>var wpcf7={"apiSettings":{"root":"https:\/\/www.catholic.sg\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/uploads/cache/fvm/1605152371/out/footer-18ace5357efecc06d300f84d857355bd4a573f00.min.js'></script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6Lf3BMUUAAAAAMzF2qHrx-r0Y7uRpp0q-dnjS-Jb&#038;ver=3.0'></script><script type='text/javascript'>var wpcf7_recaptcha={"sitekey":"6Lf3BMUUAAAAAMzF2qHrx-r0Y7uRpp0q-dnjS-Jb","actions":{"homepage":"homepage","contactform":"contactform"}};var simcal_default_calendar={"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"9057336b42","locale":"en_GB","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};var fusionVideoGeneralVars={"status_vimeo":"0","status_yt":"1"};var fusionLightboxVideoVars={"lightbox_video_width":"1280","lightbox_video_height":"720"};var fusionLightboxVars={"status_lightbox":"1","lightbox_gallery":"1","lightbox_skin":"dark","lightbox_title":"","lightbox_arrows":"1","lightbox_slideshow_speed":"15000","lightbox_autoplay":"","lightbox_opacity":"0.70","lightbox_desc":"1","lightbox_social":"","lightbox_deeplinking":"","lightbox_path":"horizontal","lightbox_post_images":"1","lightbox_animation_speed":"slow"};var avadaPortfolioVars={"lightbox_behavior":"all","infinite_finished_msg":"<em>All items displayed.<\/em>","infinite_blog_text":"<em>Loading the next set of posts...<\/em>","content_break_point":"800"};var fusionBgImageVars={"content_break_point":"800"};var fusionEqualHeightVars={"content_break_point":"800"};var fusionVideoBgVars={"status_vimeo":"0","status_yt":"1"};var fusionContainerVars={"content_break_point":"800","container_hundred_percent_height_mobile":"0","is_sticky_header_transparent":"1"};var fusionCountersBox={"counter_box_speed":"1000"};var fusionMapsVars={"admin_ajax":"https:\/\/www.catholic.sg\/wp-admin\/admin-ajax.php"};var fusionRecentPostsVars={"infinite_loading_text":"<em>Loading the next set of posts...<\/em>","infinite_finished_msg":"<em>All items displayed.<\/em>"};var fusionTabVars={"content_break_point":"800"};var fusionTestimonialVars={"testimonials_speed":"4000"};var fusionVideoVars={"status_vimeo":"0"};var fusionCarouselVars={"related_posts_speed":"2500","carousel_speed":"5000"};var fusionFlexSliderVars={"status_vimeo":"","slideshow_autoplay":"1","slideshow_speed":"7000","pagination_video_slide":"","status_yt":"1","flex_smoothHeight":"true"};var fusionBlogVars={"infinite_blog_text":"<em>Loading the next set of posts...<\/em>","infinite_finished_msg":"<em>All items displayed.<\/em>","slideshow_autoplay":"1","lightbox_behavior":"all","blog_pagination_type":"pagination"};var avadaHeaderVars={"header_position":"top","header_sticky":"1","header_sticky_type2_layout":"menu_and_logo","header_sticky_shadow":"1","side_header_break_point":"800","header_sticky_mobile":"1","header_sticky_tablet":"1","mobile_menu_design":"modern","sticky_header_shrinkage":"1","nav_height":"43","nav_highlight_border":"3","nav_highlight_style":"bar","logo_margin_top":"0px","logo_margin_bottom":"5px","layout_mode":"wide","header_padding_top":"0px","header_padding_bottom":"0px","scroll_offset":"full"};var avadaMenuVars={"site_layout":"wide","header_position":"top","logo_alignment":"center","header_sticky":"1","header_sticky_mobile":"1","header_sticky_tablet":"1","side_header_break_point":"800","megamenu_base_width":"custom_width","mobile_menu_design":"modern","dropdown_goto":"Go to...","mobile_nav_cart":"Shopping Cart","mobile_submenu_open":"Open submenu of %s","mobile_submenu_close":"Close submenu of %s","submenu_slideout":"1"};var fusionScrollToAnchorVars={"content_break_point":"800","container_hundred_percent_height_mobile":"0"};var fusionTypographyVars={"site_width":"1100px","typography_responsive":"1","typography_sensitivity":"0.60","typography_factor":"1.00","elements":"h1, h2, h3, h4, h5, h6"};var avadaCommentVars={"title_style_type":"none","title_margin_top":"20px","title_margin_bottom":"20px"};var avadaSidebarsVars={"header_position":"top","header_layout":"v5","header_sticky":"1","header_sticky_type2_layout":"menu_and_logo","side_header_break_point":"800","header_sticky_tablet":"1","sticky_header_shrinkage":"1","nav_height":"43","sidebar_break_point":"800"};var toTopscreenReaderText={"label":"Go to Top"};var avadaToTopVars={"status_totop":"desktop","totop_position":"right","totop_scroll_down_only":"0"};var avadaSelectVars={"avada_drop_down":"1"};var avadaParallaxFooterVars={"side_header_break_point":"800","header_position":"top"};var avadaElasticSliderVars={"tfes_autoplay":"1","tfes_animation":"sides","tfes_interval":"3000","tfes_speed":"800","tfes_width":"150"};var avadaFusionSliderVars={"side_header_break_point":"800","slider_position":"below","header_transparency":"0","mobile_header_transparency":"0","header_position":"top","content_break_point":"800","status_vimeo":"0"};</script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/uploads/cache/fvm/1605152371/out/footer-fff31454536a40fa46e61c553ddaafaa5042f1de.min.js'></script> <script type="text/javascript">jQuery(document).ready(function(){var ajaxurl='https://www.catholic.sg/wp-admin/admin-ajax.php';if(0<jQuery('.fusion-login-nonce').length){jQuery.get(ajaxurl,{'action':'fusion_login_nonce'},function(response){jQuery('.fusion-login-nonce').html(response);});}});</script> <script defer id="io.birdseed.script-tag" type="text/javascript" src="https://app.birdseed.io/widget.js"></script><div id="birdseed-widget-container" data-token="da71e1f11ea1e9d3ee4086bc4279d1b6"></div> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-58885675-2"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','UA-58885675-2');</script> </div></body></html> 