<!DOCTYPE html><html class="avada-html-layout-wide avada-html-header-position-top" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><head><meta http-equiv="X-UA-Compatible" content="IE=edge" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /><title>05 May, 2020, Tuesday, 4th Week of Easter &#8211; Roman Catholic Archdiocese of Singapore</title><meta name="wpacu-generator" content="ASSET CLEANUP STYLES PRELOADS"><meta name="wpacu-generator" content="ASSET CLEANUP SCRIPTS PRELOADS"><link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//cdn.datatables.net' /><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//use.fontawesome.com' /><link rel='dns-prefetch' href='//s.w.org' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Roman Catholic Archdiocese of Singapore &raquo; Feed" href="https://www.catholic.sg/feed/" /><link rel="alternate" type="application/rss+xml" title="Roman Catholic Archdiocese of Singapore &raquo; Comments Feed" href="https://www.catholic.sg/comments/feed/" /><link rel="alternate" type="text/calendar" title="Roman Catholic Archdiocese of Singapore &raquo; iCal Feed" href="https://www.catholic.sg/events/?ical=1" /><link rel="shortcut icon" href="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-20.png" type="image/x-icon" /><link rel="apple-touch-icon" href="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-57-1.png"><link rel="apple-touch-icon" sizes="114x114" href="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-114.png"><link rel="apple-touch-icon" sizes="72x72" href="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-72.png"><link rel="apple-touch-icon" sizes="144x144" href="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-144.png"><meta property="og:title" content="05 May, 2020, Tuesday, 4th Week of Easter" /><meta property="og:type" content="article" /><meta property="og:url" content="https://www.catholic.sg/05-may-2020-tuesday-4th-week-of-easter/" /><meta property="og:site_name" content="Roman Catholic Archdiocese of Singapore" /><meta property="og:description" content="A CHURCH THAT GOES OUTSCRIPTURE READINGS:
The greatest danger of the Catholic Church is that of being fossilized.  The Catholic Church is more than 2000 years old.  Singapore will only be 55 years old this year in August.  If we think 55 years" /><meta property="og:image" content="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_tight_crop_280.png" /><link data-wpacu-style-handle='tribe-common-skeleton-style' rel='stylesheet' id='tribe-common-skeleton-style-css' href='https://www.catholic.sg/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.9.21' type='text/css' media='all' /><style type='text/css' data-wpacu-inline-css-file='1'>
.tribe-tooltip{cursor:pointer;display:inline-block;margin:0;position:relative;text-align:left}.tribe-tooltip .dashicons-info{color:#a9a9a9;font-size:16px;line-height:1em;vertical-align:middle}.tribe-tooltip .down,.tribe-tooltip .left,.tribe-tooltip .right,.tribe-tooltip .up{background-color:#fff;box-shadow:0 0 3px 3px rgba(4,5,5,.05);box-sizing:border-box;color:#333;font-size:16px;font-weight:400;max-weight:100vw;opacity:0;padding:15px;position:absolute;transform:translate(-50%);transition:opacity .8s;visibility:hidden;width:250px;z-index:99999999}.tribe-tooltip .down i,.tribe-tooltip .left i,.tribe-tooltip .right i,.tribe-tooltip .up i{height:12px;overflow:hidden;position:absolute;width:24px}.tribe-tooltip .down i:after,.tribe-tooltip .left i:after,.tribe-tooltip .right i:after,.tribe-tooltip .up i:after{background-color:#fff;content:"";height:12px;position:absolute;width:24px}.tribe-tooltip.large .down,.tribe-tooltip.large .left,.tribe-tooltip.large .right,.tribe-tooltip.large .up{width:400px}.tribe-tooltip .tooltip-list{padding-left:10px}.tribe-tooltip .tooltip-list li{list-style-type:disc}.tribe-tooltip .down{left:50%;top:28px}.tribe-tooltip .down i{bottom:100%;left:50%;margin-left:-7px}.tribe-tooltip .down i:after{box-shadow:0 0 3px 3px rgba(4,5,5,.05);left:50%;top:50%;transform:translate(-50%,50%) rotate(45deg)}.tribe-tooltip.active .down,.tribe-tooltip.active .left,.tribe-tooltip.active .right,.tribe-tooltip.active .up{opacity:1;visibility:visible}@media screen and (max-width:480px){.tribe-tooltip.large .down,.tribe-tooltip.large .left,.tribe-tooltip.large .right,.tribe-tooltip.large .up{width:250px}}
</style><style type='text/css' data-wpacu-inline-css-file='1'>

</style><link data-wpacu-to-be-preloaded-basic='1' data-wpacu-style-handle='jquery-datatables' rel='stylesheet' id='jquery-datatables-css' href='https://cdn.datatables.net/1.10.16/css/jquery.dataTables.min.css?ver=5.3' type='text/css' media='all' /><link data-wpacu-to-be-preloaded-basic='1' data-wpacu-style-handle='datatables-buttons' rel='stylesheet' id='datatables-buttons-css' href='https://cdn.datatables.net/buttons/1.4.2/css/buttons.dataTables.min.css?ver=5.3' type='text/css' media='all' /><link data-wpacu-to-be-preloaded-basic='1' data-wpacu-style-handle='datatables-select' rel='stylesheet' id='datatables-select-css' href='https://cdn.datatables.net/select/1.2.3/css/select.dataTables.min.css?ver=5.3' type='text/css' media='all' /><link data-wpacu-to-be-preloaded-basic='1' data-wpacu-style-handle='datatables-fixedheader' rel='stylesheet' id='datatables-fixedheader-css' href='https://cdn.datatables.net/fixedheader/3.1.3/css/fixedHeader.dataTables.min.css?ver=5.3' type='text/css' media='all' /><link data-wpacu-to-be-preloaded-basic='1' data-wpacu-style-handle='datatables-fixedcolumns' rel='stylesheet' id='datatables-fixedcolumns-css' href='https://cdn.datatables.net/fixedcolumns/3.2.3/css/fixedColumns.dataTables.min.css?ver=5.3' type='text/css' media='all' /><link data-wpacu-to-be-preloaded-basic='1' data-wpacu-style-handle='datatables-responsive' rel='stylesheet' id='datatables-responsive-css' href='https://cdn.datatables.net/responsive/2.2.0/css/responsive.dataTables.min.css?ver=5.3' type='text/css' media='all' /><style type='text/css' data-wpacu-inline-css-file='1'>
#wp-admin-bar-hit_counter .ab-item:before{content:"\f115";top:2px}
</style><link data-wpacu-style-handle='pbx-public' rel='stylesheet' id='pbx-public-css' href='https://www.catholic.sg/wp-content/plugins/praybox-plus/css/pbx-public.css?ver=5.3' type='text/css' media='all' /><link data-wpacu-style-handle='yop-public' rel='stylesheet' id='yop-public-css' href='https://www.catholic.sg/wp-content/plugins/yop-poll/public/assets/css/yop-poll-public-6.1.4.css?ver=5.3' type='text/css' media='all' /><link data-wpacu-style-handle='fusion-core-style' rel='stylesheet' id='fusion-core-style-css' href='https://www.catholic.sg/wp-content/plugins/fusion-core/css/style.min.css?ver=5.3' type='text/css' media='all' /><link data-wpacu-style-handle='avada-stylesheet' rel='stylesheet' id='avada-stylesheet-css' href='https://www.catholic.sg/wp-content/themes/Avada/assets/css/style.min.css?ver=6.1.1' type='text/css' media='all' /><style id='avada-stylesheet-inline-css' type='text/css'>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</style><!--[if IE]><link
data-wpacu-style-handle='avada-IE' rel='stylesheet' id='avada-IE-css'  href='https://www.catholic.sg/wp-content/themes/Avada/assets/css/ie.min.css?ver=6.1.1' type='text/css' media='all' /><style id='avada-IE-inline-css' type='text/css'>.avada-select-parent .select-arrow{background-color:#fff}.select-arrow{background-color:#fff}</style><![endif]--><style type='text/css' data-wpacu-inline-css-file='1'>
.widget_most_viewed .post-views{display:block}
</style><link data-wpacu-to-be-preloaded-basic='1' data-wpacu-style-handle='font-awesome-official' rel='stylesheet' id='font-awesome-official-css' href='https://use.fontawesome.com/releases/v5.9.0/css/all.css' type='text/css' media='all' integrity="sha384-i1LQnF23gykqWXg6jxC2ZbCbUMxyw5gLZY6UiUS98LYV5unm8GWmfkIS6jqJfb4E" crossorigin="anonymous" /><link data-wpacu-style-handle='tablepress-default' rel='stylesheet' id='tablepress-default-css' href='https://www.catholic.sg/wp-content/uploads/tablepress-combined.min.css?ver=34' type='text/css' media='all' /><style type='text/css' data-wpacu-inline-css-file='1'>
.clear{clear:both}.nobr{white-space:nowrap}.lazy-hidden,.entry img.lazy-hidden,img.thumbnail.lazy-hidden{background-color:#fff}
</style><style type='text/css' data-wpacu-inline-css-file='1'>
.addtoany_content{clear:both;margin:16px 0}.addtoany_header{margin:0 0 16px}.addtoany_list{display:inline;line-height:16px}.addtoany_list a,.widget .addtoany_list a{border:0;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle}.addtoany_list a img{border:0;display:inline-block;opacity:1;overflow:hidden;vertical-align:baseline}.addtoany_list a span{display:inline-block;float:none}.addtoany_list.a2a_kit_size_32 a{font-size:32px}.addtoany_list.a2a_kit_size_32 a:not(.addtoany_special_service)>span{height:32px;line-height:32px;width:32px}.addtoany_list a:not(.addtoany_special_service)>span{border-radius:4px;display:inline-block;opacity:1}.addtoany_list a .a2a_count{position:relative;vertical-align:top}.addtoany_list a:hover,.widget .addtoany_list a:hover{border:0;box-shadow:none}.addtoany_list a:hover img,.addtoany_list a:hover span{opacity:.7}.addtoany_list a.addtoany_special_service:hover img,.addtoany_list a.addtoany_special_service:hover span{opacity:1}.addtoany_special_service{display:inline-block;vertical-align:middle}.addtoany_special_service a,.addtoany_special_service div,.addtoany_special_service div.fb_iframe_widget,.addtoany_special_service iframe,.addtoany_special_service span{margin:0;vertical-align:baseline!important}.addtoany_special_service iframe{display:inline;max-width:none}a.addtoany_share.addtoany_no_icon span.a2a_img_text{display:none}a.addtoany_share img{border:0;width:auto;height:auto}
</style><style type='text/css' media='only screen and (max-width: 644px)' data-wpacu-inline-css-file='1'>
.fusion-blog-layout-grid-6 .fusion-post-grid,.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post{width:100%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-landscape .fusion-masonry-element-container,.fusion-grid-6 .fusion-grid-column.fusion-element-landscape .fusion-masonry-element-container,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape .fusion-masonry-element-container{padding-top:65%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-grid .fusion-masonry-element-container,.fusion-grid-6 .fusion-grid-column.fusion-element-grid .fusion-masonry-element-container,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-grid .fusion-masonry-element-container{padding-top:100%!important}
</style><style type='text/css' media='only screen and (max-width: 735px)' data-wpacu-inline-css-file='1'>
.fusion-blog-layout-grid .fusion-post-grid,.fusion-grid-column,.fusion-portfolio-post{width:100%!important}.fusion-blog-layout-grid .fusion-post-grid.fusion-element-landscape .fusion-masonry-element-container,.fusion-grid-column.fusion-element-landscape .fusion-masonry-element-container,.fusion-portfolio-post.fusion-element-landscape .fusion-masonry-element-container{padding-top:65%!important}.fusion-blog-layout-grid .fusion-post-grid.fusion-element-grid .fusion-masonry-element-container,.fusion-grid-column.fusion-element-grid .fusion-masonry-element-container,.fusion-portfolio-post.fusion-element-grid .fusion-masonry-element-container{padding-top:100%!important}.fusion-portfolio-grid:not(.fusion-portfolio-text) .fusion-portfolio-post .fusion-image-wrapper{display:block;text-align:center}.fusion-blog-layout-grid-6 .fusion-post-grid,.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post{width:50%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-landscape,.fusion-grid-6 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape{width:100%!important}
</style><style type='text/css' media='only screen and (min-width: 735px) and (max-width: 826px)' data-wpacu-inline-css-file='1'>
.fusion-blog-layout-grid-6 .fusion-post-grid,.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post{width:33.3333333333%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-landscape,.fusion-grid-6 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape{width:66.6666666666%!important}.fusion-blog-layout-grid-3 .fusion-post-grid,.fusion-blog-layout-grid-4 .fusion-post-grid,.fusion-blog-layout-grid-5 .fusion-post-grid,.fusion-grid-3 .fusion-grid-column,.fusion-grid-4 .fusion-grid-column,.fusion-grid-5 .fusion-grid-column,.fusion-portfolio-five .fusion-portfolio-post,.fusion-portfolio-four .fusion-portfolio-post,.fusion-portfolio-masonry .fusion-portfolio-post,.fusion-portfolio-three .fusion-portfolio-post{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-4 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape,.fusion-grid-3 .fusion-grid-column.fusion-element-landscape,.fusion-grid-4 .fusion-grid-column.fusion-element-landscape,.fusion-grid-5 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-five .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-four .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-masonry .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-three .fusion-portfolio-post.fusion-element-landscape{width:100%!important}
</style><style type='text/css' media='only screen and (min-width: 826px) and (max-width: 917px)' data-wpacu-inline-css-file='1'>
.fusion-blog-layout-grid-6 .fusion-post-grid,.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post{width:25%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-landscape,.fusion-grid-6 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid,.fusion-blog-layout-grid-4 .fusion-post-grid,.fusion-blog-layout-grid-5 .fusion-post-grid,.fusion-grid-3 .fusion-grid-column,.fusion-grid-4 .fusion-grid-column,.fusion-grid-5 .fusion-grid-column,.fusion-portfolio-five .fusion-portfolio-post,.fusion-portfolio-four .fusion-portfolio-post,.fusion-portfolio-three .fusion-portfolio-post{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-4 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape,.fusion-grid-3 .fusion-grid-column.fusion-element-landscape,.fusion-grid-4 .fusion-grid-column.fusion-element-landscape,.fusion-grid-5 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-five .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-four .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-three .fusion-portfolio-post.fusion-element-landscape{width:100%!important}
</style><style type='text/css' media='only screen and (min-width: 917px) and (max-width: 1008px)' data-wpacu-inline-css-file='1'>
.fusion-blog-layout-grid-6 .fusion-post-grid,.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post{width:20%!important}.fusion-blog-layout-grid-6 .fusion-post-grid.fusion-element-landscape,.fusion-grid-6 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape{width:40%!important}.fusion-blog-layout-grid-4 .fusion-post-grid,.fusion-blog-layout-grid-5 .fusion-post-grid,.fusion-grid-4 .fusion-grid-column,.fusion-grid-5 .fusion-grid-column,.fusion-portfolio-five .fusion-portfolio-post,.fusion-portfolio-four .fusion-portfolio-post{width:33.3333333333%!important}.fusion-blog-layout-grid-4 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape,.fusion-grid-4 .fusion-grid-column.fusion-element-landscape,.fusion-grid-5 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-five .fusion-portfolio-post.fusion-element-landscape,.fusion-portfolio-four .fusion-portfolio-post.fusion-element-landscape{width:66.6666666666%!important}
</style><style type='text/css' media='only screen and (min-width: 1008px) and (max-width: 1099px)' data-wpacu-inline-css-file='1'>
.fusion-grid-6 .fusion-grid-column,.fusion-portfolio-six .fusion-portfolio-post,.grid-layout-6 .fusion-post-grid{width:20%!important}.fusion-grid-6 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-six .fusion-portfolio-post.fusion-element-landscape,.grid-layout-6 .fusion-post-grid.fusion-element-landscape{width:40%!important}.fusion-blog-layout-grid-5 .fusion-post-grid,.fusion-grid-5 .fusion-grid-column,.fusion-portfolio-five .fusion-portfolio-post{width:25%!important}.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape,.fusion-grid-5 .fusion-grid-column.fusion-element-landscape,.fusion-portfolio-five .fusion-portfolio-post.fusion-element-landscape{width:50%!important}
</style><link data-wpacu-style-handle='avada-min-shbp' rel='stylesheet' id='avada-min-shbp-css' href='https://www.catholic.sg/wp-content/themes/Avada/assets/css/media/min-shbp.min.css?ver=6.1.1' type='text/css' media='only screen and (min-width: 801px)' /><link data-wpacu-style-handle='avada-max-shbp' rel='stylesheet' id='avada-max-shbp-css' href='https://www.catholic.sg/wp-content/themes/Avada/assets/css/media/max-shbp.min.css?ver=6.1.1' type='text/css' media='only screen and (max-width: 800px)' /><link data-wpacu-style-handle='avada-max-sh-shbp' rel='stylesheet' id='avada-max-sh-shbp-css' href='https://www.catholic.sg/wp-content/themes/Avada/assets/css/media/max-sh-shbp.min.css?ver=6.1.1' type='text/css' media='only screen and (max-width: 800px)' /><link data-wpacu-style-handle='avada-min-768-max-1024-p' rel='stylesheet' id='avada-min-768-max-1024-p-css' href='https://www.catholic.sg/wp-content/themes/Avada/assets/css/media/min-768-max-1024-p.min.css?ver=6.1.1' type='text/css' media='only screen and (min-device-width: 768px) and (max-device-width: 1024px) and (orientation: portrait)' /><style type='text/css' media='only screen and (min-device-width: 768px) and (max-device-width: 1024px) and (orientation: landscape)' data-wpacu-inline-css-file='1'>
.fullwidth-box{background-attachment:scroll!important}.fullwidth-box .fullwidth-faded{background-attachment:scroll!important}.avada-footer-fx-bg-parallax .fusion-footer-widget-area{background-attachment:initial;margin:0}.avada-footer-fx-bg-parallax #main{margin-bottom:0}#main,.fullwidth-box,.fusion-footer-widget-area,.page-title-bar,body{background-attachment:scroll!important}.avada-responsive.rtl .fusion-header-v1 .fusion-main-menu>ul>li,.avada-responsive.rtl .fusion-header-v2 .fusion-main-menu>ul>li,.avada-responsive.rtl .fusion-header-v3 .fusion-main-menu>ul>li,.avada-responsive.rtl .fusion-header-v4 .fusion-main-menu>ul>li,.avada-responsive.rtl .fusion-header-v5 .fusion-main-menu>ul>li,.avada-responsive.rtl .fusion-header-v7 .fusion-main-menu>ul>li{padding-left:var(--mobile_nav_padding)}.avada-responsive:not(.rtl) .fusion-header-v1 .fusion-main-menu>ul>li,.avada-responsive:not(.rtl) .fusion-header-v2 .fusion-main-menu>ul>li,.avada-responsive:not(.rtl) .fusion-header-v3 .fusion-main-menu>ul>li,.avada-responsive:not(.rtl) .fusion-header-v4 .fusion-main-menu>ul>li,.avada-responsive:not(.rtl) .fusion-header-v5 .fusion-main-menu>ul>li,.avada-responsive:not(.rtl) .fusion-header-v7 .fusion-main-menu>ul>li{padding-right:var(--mobile_nav_padding)}
</style><link data-wpacu-style-handle='avada-max-sh-cbp' rel='stylesheet' id='avada-max-sh-cbp-css' href='https://www.catholic.sg/wp-content/themes/Avada/assets/css/media/max-sh-cbp.min.css?ver=6.1.1' type='text/css' media='only screen and (max-width: 800px)' /><style type='text/css' media='only screen and (max-width: 800px)' data-wpacu-inline-css-file='1'>
#content{width:100%!important;margin-left:0!important}.sidebar{width:100%!important;float:none!important;margin-left:0!important;clear:both}#main>.fusion-row{display:-ms-flexbox;display:flex;-ms-flex-wrap:wrap;flex-wrap:wrap}
</style><style type='text/css' media='only screen and (max-width: 640px)' data-wpacu-inline-css-file='1'>
.fusion-body .fusion-page-title-bar{max-height:none}.fusion-body .fusion-page-title-bar h1{margin:0}.fusion-body .fusion-blog-layout-medium .fusion-post-slideshow{float:none;margin:0 0 20px;width:auto;height:auto;-ms-flex:0 1 100%;flex:0 1 100%}.fusion-body .fusion-blog-layout-medium .fusion-post-content{-ms-flex:0 1 100%;flex:0 1 100%}.fusion-body .fusion-blog-layout-large-alternate .fusion-post-content{margin:0}.fusion-blog-layout-large .fusion-meta-info .fusion-alignleft,.fusion-blog-layout-large .fusion-meta-info .fusion-alignright,.fusion-blog-layout-medium .fusion-meta-info .fusion-alignleft,.fusion-blog-layout-medium .fusion-meta-info .fusion-alignright{display:block;float:none;margin:0;width:100%}.fusion-blog-layout-large-alternate .fusion-date-and-formats{margin-bottom:35px}.fusion-blog-layout-medium-alternate .has-post-thumbnail .fusion-post-slideshow{display:inline-block;float:none;margin-right:0;max-width:197px}.fusion-blog-layout-grid .fusion-post-grid{position:static;width:100%}.flex-direction-nav,.wooslider-direction-nav,.wooslider-pauseplay{display:none}.share-box ul li{margin-bottom:10px;margin-right:15px}.share-box .social-networks li{margin-right:20px!important}.buttons a{margin-right:5px}.ls-avada .ls-nav-next,.ls-avada .ls-nav-prev{display:none!important}#wrapper .ei-slider{width:100%!important;height:200px!important}#wrapper .share-box h4{display:block;float:none;line-height:20px!important;margin-top:0;padding:0;margin-bottom:10px}.page-template-contact-php .fusion-google-map{height:270px!important}.timeline-icon{display:none!important}.timeline-layout{padding-top:0!important}.portfolio-masonry .portfolio-item{width:100%!important}.table-1 table,.tkt-slctr-tbl-wrap-dv table{border-collapse:collapse;border-spacing:0;width:100%}.table-1 td,.table-1 th,.tkt-slctr-tbl-wrap-dv td,.tkt-slctr-tbl-wrap-dv th{white-space:nowrap}.table-2 table{border-collapse:collapse;border-spacing:0;width:100%}.table-2 td,.table-2 th{white-space:nowrap}#main,.footer-area,.page-title-bar,body{background-attachment:scroll!important}.tfs-slider[data-animation=slide]{height:auto!important}.fusion-sharing-box .fusion-social-networks{float:none;display:block;width:100%;text-align:left}#content{width:100%!important;margin-left:0!important}.sidebar{width:100%!important;float:none!important;margin-left:0!important;clear:both}.fusion-hide-on-mobile{display:none}.fusion-blog-layout-timeline{padding-top:0}.fusion-blog-layout-timeline .fusion-post-timeline{float:none;width:100%}.fusion-blog-layout-timeline .fusion-timeline-date{margin-bottom:0;margin-top:2px}.fusion-timeline-arrow,.fusion-timeline-circle,.fusion-timeline-icon,.fusion-timeline-line{display:none}
</style><style type='text/css' media='only screen and (max-width: 782px)' data-wpacu-inline-css-file='1'>
.admin-bar p.woocommerce-store-notice,body.admin-bar #wrapper .fusion-sliding-bar-position-top,body.layout-boxed-mode.side-header-right .fusion-sliding-bar-position-top{top:46px}body.fusion-blank-page.admin-bar{top:45px}html #wpadminbar{z-index:99999!important;position:fixed!important}
</style><style type='text/css' media='only screen and (max-width: 768px)' data-wpacu-inline-css-file='1'>
.fusion-tabs.vertical-tabs .tab-pane{max-width:none!important}
</style><style type='text/css' media='only screen and (min-width: 800px)' data-wpacu-inline-css-file='1'>
.ilightbox-holder.supportTouch div.ilightbox-container{overflow:visible}.widget.tweets.fusion-widget-align-right .jtwt .jtwt_tweet{padding-left:0;padding-right:45px}.widget.tweets.fusion-widget-align-right .jtwt .jtwt_tweet:before{margin-left:0;right:0}.widget.tweets.fusion-widget-align-center .jtwt .jtwt_tweet{padding:0}.widget.tweets.fusion-widget-align-center .jtwt .jtwt_tweet:before{top:0;position:relative;margin:0}.widget.tribe-events-list-widget.fusion-widget-align-right .tribe-events-list-widget-events{-ms-flex-pack:end;justify-content:end}.widget.tribe-events-list-widget.fusion-widget-align-center .tribe-events-list-widget-events{-ms-flex-pack:center;justify-content:center}.fusion-body .fusion-footer-widget-area-center .widget.tweets:not(.fusion-widget-align-left):not(.fusion-widget-align-right) .jtwt .jtwt_tweet{padding:0}.fusion-body .fusion-footer-widget-area-center .widget.tweets:not(.fusion-widget-align-left):not(.fusion-widget-align-right) .jtwt .jtwt_tweet:before{top:0;position:relative;margin:0}.no-overflow-y body{padding-right:9px!important}.no-overflow-y .modal{overflow-y:hidden}.no-overflow-y .fusion-sliding-bar-position-bottom,.no-overflow-y .fusion-sliding-bar-position-top{right:9px}.no-desktop-totop .to-top-container{display:none}
</style><link data-wpacu-style-handle='avada-max-640' rel='stylesheet' id='avada-max-640-css' href='https://www.catholic.sg/wp-content/themes/Avada/assets/css/media/max-640.min.css?ver=6.1.1' type='text/css' media='only screen and (max-device-width: 640px)' /><style type='text/css' media='only screen and (max-width: 800px)' data-wpacu-inline-css-file='1'>
.wpcf7-form .wpcf7-number,.wpcf7-form .wpcf7-quiz,.wpcf7-form .wpcf7-text,.wpcf7-form textarea{float:none!important;width:100%!important;box-sizing:border-box}
</style><style type='text/css' media='only screen and (max-width: 800px)' data-wpacu-inline-css-file='1'>
.ei-title{position:absolute;right:0;margin-right:0;width:100%;text-align:center;top:28%;padding:5px 0}.ei-title h2,.ei-title h3{text-align:center}#wrapper .ei-title h2{font-size:20px;line-height:24px}#wrapper .ei-title h3{font-size:15px;line-height:30px}
</style><link data-wpacu-style-handle='avada-max-768-ec' rel='stylesheet' id='avada-max-768-ec-css' href='https://www.catholic.sg/wp-content/themes/Avada/assets/css/media/max-768-ec.min.css?ver=6.1.1' type='text/css' media='only screen and (max-width: 768px)' /><link data-wpacu-style-handle='avada-max-sh-cbp-ec' rel='stylesheet' id='avada-max-sh-cbp-ec-css' href='https://www.catholic.sg/wp-content/themes/Avada/assets/css/media/max-sh-cbp-ec.min.css?ver=6.1.1' type='text/css' media='only screen and (max-width: 800px)' /><style type='text/css' media='only screen and (max-width: 800px)' data-wpacu-inline-css-file='1'>
.fusion-layout-column{margin-left:0!important;margin-right:0!important;width:100%!important}.fusion-layout-column.fusion-spacing-no{margin-bottom:0}.fusion-columns-1 .fusion-column:first-child,.fusion-columns-2 .fusion-column:first-child,.fusion-columns-3 .fusion-column:first-child,.fusion-columns-4 .fusion-column:first-child,.fusion-columns-5 .fusion-column:first-child{margin-left:0}.fusion-columns .fusion-column{width:100%!important;float:none;-webkit-box-sizing:border-box;box-sizing:border-box}.fusion-columns .fusion-column:not(.fusion-column-last){margin:0 0 50px}.rtl .fusion-columns{float:none}.col-sm-12,.col-sm-2,.col-sm-3,.col-sm-4,.col-sm-6,.fusion-columns-5 .col-lg-2,.fusion-columns-5 .col-md-2,.fusion-columns-5 .col-sm-2{float:none;width:100%}.fusion-blog-layout-medium-alternate .fusion-post-content,.fusion-blog-layout-medium-alternate .has-post-thumbnail .fusion-post-content{margin:0;padding-top:20px;-webkit-box-flex:1;-ms-flex:1 0 100%;flex:1 0 100%}.fusion-chart.legend-left .fusion-chart-inner,.fusion-chart.legend-right .fusion-chart-inner{-webkit-box-orient:vertical;-webkit-box-direction:normal;-ms-flex-direction:column;flex-direction:column}.fusion-chart.legend-left .fusion-chart-inner .fusion-chart-legend-wrap li,.fusion-chart.legend-right .fusion-chart-inner .fusion-chart-legend-wrap li{display:inline-block}.fusion-chart.legend-left .fusion-chart-legend-wrap,.fusion-chart.legend-right .fusion-chart-legend-wrap{padding-top:20px}.fusion-chart.legend-right .fusion-chart-legend-wrap{padding-left:0}.fusion-chart.legend-left .fusion-chart-legend-wrap{padding-right:0;-webkit-box-ordinal-group:3;-ms-flex-order:2;order:2}.fusion-content-boxes .fusion-column{margin-bottom:55px}.fusion-content-boxes .fusion-read-more-button{margin-top:8px}.fusion-tabs.vertical-tabs .nav-tabs>li.active>.tab-link{border-left:3px solid var(--primary_color)}
</style><link data-wpacu-style-handle='fb-min-768-max-1024-p' rel='stylesheet' id='fb-min-768-max-1024-p-css' href='https://www.catholic.sg/wp-content/plugins/fusion-builder/assets/css/media/min-768-max-1024-p.min.css?ver=2.1.1' type='text/css' media='only screen and (min-device-width: 768px) and (max-device-width: 1024px) and (orientation: portrait)' /><style type='text/css' media='only screen and (max-device-width: 640px)' data-wpacu-inline-css-file='1'>
.fusion-columns .fusion-column{float:none;width:100%!important;margin:0 0 50px;-webkit-box-sizing:border-box;box-sizing:border-box}.fusion-blog-layout-large .fusion-meta-info .fusion-alignleft,.fusion-blog-layout-large .fusion-meta-info .fusion-alignright,.fusion-blog-layout-medium .fusion-meta-info .fusion-alignleft,.fusion-blog-layout-medium .fusion-meta-info .fusion-alignright{display:block;float:none;margin:0;width:100%}.fusion-blog-layout-medium .fusion-post-slideshow{margin:0 0 20px 0;height:auto;width:auto;-webkit-box-flex:1;-ms-flex:1 0 100%;flex:1 0 100%}.fusion-blog-layout-medium .fusion-post-content{-webkit-box-flex:0;-ms-flex:0 1 100%;flex:0 1 100%}.fusion-blog-layout-large-alternate .fusion-date-and-formats{margin-bottom:35px}.fusion-blog-layout-large-alternate .fusion-post-content{margin:0}.fusion-blog-layout-medium-alternate .has-post-thumbnail .fusion-post-slideshow{display:inline-block;margin-right:0;max-width:197px}.fusion-blog-layout-grid .fusion-post-grid{position:static;width:100%}.fusion-blog-layout-timeline{padding-top:0}.fusion-blog-layout-timeline .fusion-post-timeline{float:none;width:100%}.fusion-blog-layout-timeline .fusion-timeline-date{margin-bottom:0;margin-top:2px}.fusion-timeline-arrow,.fusion-timeline-circle,.fusion-timeline-icon,.fusion-timeline-line{display:none}
</style><style type='text/css' media='only screen and (max-width: 644px)' data-wpacu-inline-css-file='1'>
.fusion-blog-layout-grid-6 .fusion-post-grid{width:100%!important}
</style><style type='text/css' media='only screen and (max-width: 735px)' data-wpacu-inline-css-file='1'>
.fusion-blog-layout-grid .fusion-post-grid{width:100%!important}.fusion-blog-layout-grid-6 .fusion-post-grid{width:50%!important}.fusion-blog-layout-grid-6 .fusion-element-landscape{width:100%!important}
</style><style type='text/css' media='only screen and (min-width: 735px) and (max-width: 826px)' data-wpacu-inline-css-file='1'>
.fusion-blog-layout-grid-6 .fusion-post-grid{width:33.33333333%!important}.fusion-blog-layout-grid-6 .fusion-element-landscape{width:66.66666667%!important}.fusion-blog-layout-grid-3 .fusion-post-grid,.fusion-blog-layout-grid-4 .fusion-post-grid,.fusion-blog-layout-grid-5 .fusion-post-grid{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-4 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape{width:100%!important}
</style><style type='text/css' media='only screen and (min-width: 826px) and (max-width: 917px)' data-wpacu-inline-css-file='1'>
.fusion-blog-layout-grid-6 .fusion-post-grid{width:25%!important}.fusion-blog-layout-grid-6 .fusion-element-landscape{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid,.fusion-blog-layout-grid-4 .fusion-post-grid,.fusion-blog-layout-grid-5 .fusion-post-grid{width:50%!important}.fusion-blog-layout-grid-3 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-4 .fusion-post-grid.fusion-element-landscape,.fusion-blog-layout-grid-5 .fusion-post-grid.fusion-element-landscape{width:100%!important}
</style><style type='text/css' media='only screen and (min-width: 917px) and (max-width: 1008px)' data-wpacu-inline-css-file='1'>
.fusion-blog-layout-grid-6 .fusion-post-grid{width:20%!important}.fusion-blog-layout-grid-6 .fusion-element-landscape{width:40%!important}.fusion-blog-layout-grid-5 .fusion-post-grid{width:33.33333333%!important}.fusion-blog-layout-grid-5 .fusion-element-landscape{width:66.66666667%!important}.fusion-blog-layout-grid-4 .fusion-post-grid{width:33.33333333%!important}.fusion-blog-layout-grid-4 .fusion-element-landscape{width:66.66666667%!important}
</style><style type='text/css' media='only screen and (min-width: 1008px) and (max-width: 1099px)' data-wpacu-inline-css-file='1'>
.fusion-blog-layout-grid-6 .fusion-post-grid{width:20%!important}.fusion-blog-layout-grid-6 .fusion-element-landscape{width:40%!important}.fusion-blog-layout-grid-5 .fusion-post-grid{width:25%!important}.fusion-blog-layout-grid-5 .fusion-element-landscape{width:50%!important}
</style><style type='text/css' data-wpacu-inline-css-file='1'>
div.sib-sms-field{display:inline-block;position:relative;width:100%}.sib-sms-field .sib-country-block{position:absolute;right:auto;left:0;top:0;bottom:0;padding:1px;-webkit-box-sizing:border-box;-moz-box-sizing:border-box;box-sizing:border-box}.sib-country-block .sib-toggle.sib-country-flg{z-index:1;position:relative;width:46px;height:100%;padding:0 0 0 8px;-webkit-box-sizing:border-box;-moz-box-sizing:border-box;box-sizing:border-box;background-color:#dbdbdb;cursor:pointer}.sib-country-block .sib-toggle .sib-cflags{position:absolute;top:0;bottom:0;margin:auto;height:15px;width:20px;background-repeat:no-repeat;background-color:#dbdbdb;-webkit-box-sizing:border-box;-moz-box-sizing:border-box;box-sizing:border-box;background-image:url(/wp-content/plugins/mailin/css/../img/flags/fr.png)}.sib-country-block .sib-toggle .sib-icon-arrow{position:absolute;top:50%;margin-top:-2px;right:6px;width:0;height:0;border-left:3px solid transparent;border-right:3px solid transparent;border-top:4px solid}.sib-sms-field ul.sib-country-list{position:absolute;z-index:2;list-style:none;text-align:left;padding:0;margin:0 0 0 -1px;box-shadow:rgba(0,0,0,.2) 1px 1px 4px;background-color:#fff;border:1px solid rgb(204,204,204);white-space:nowrap;max-height:150px;overflow-y:scroll;overflow-x:hidden;top:50px;width:250px}.sib-sms-field ul.sib-country-list li.sib-country-prefix{font-size:14px;padding:1px 10px;cursor:pointer}.sib-sms-field ul.sib-country-list li.sib-country-prefix:hover{background-color:#dbdbdb}.sib-sms-field ul.sib-country-list li .sib-flag-box{width:20px}.sib-sms-field ul.sib-country-list li .sib-flag-box .sib-flag{height:18px;width:20px;background-image:url(/wp-content/plugins/mailin/css/../img/flags/ad.png);vertical-align:middle;display:inline-block;background-repeat:no-repeat}.sib-sms-field ul.sib-country-list li .sib-flag-box .sib-dial-code{margin-left:20px}.sib-sms-field .sib-sms{padding-right:6px;padding-left:52px;margin-left:0;position:relative;z-index:0;margin-top:0!important;margin-bottom:0!important;margin-right:0}.sib-multi-lists.sib_error{color:#A94442}
</style><link data-wpacu-to-be-preloaded-basic='1' data-wpacu-style-handle='font-awesome-official-v4shim' rel='stylesheet' id='font-awesome-official-v4shim-css' href='https://use.fontawesome.com/releases/v5.9.0/css/v4-shims.css' type='text/css' media='all' integrity="sha384-zpflLcSaYRmTsnK2LTOdvChgML+Tt/4aE2szcblLVBXd8Jq/HGz6rhZqZ+4TkK75" crossorigin="anonymous" /><style id='font-awesome-official-v4shim-inline-css' type='text/css'>@font-face{font-family:"FontAwesome";src:url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.eot),url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.eot?#iefix") format("embedded-opentype"),url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.woff2) format("woff2"),url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.woff) format("woff"),url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.ttf) format("truetype"),url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-brands-400.svg#fontawesome") format("svg")}@font-face{font-family:"FontAwesome";src:url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.eot),url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.eot?#iefix") format("embedded-opentype"),url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.woff2) format("woff2"),url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.woff) format("woff"),url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.ttf) format("truetype"),url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-solid-900.svg#fontawesome") format("svg")}@font-face{font-family:"FontAwesome";src:url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.eot),url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.eot?#iefix") format("embedded-opentype"),url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.woff2) format("woff2"),url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.woff) format("woff"),url(https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.ttf) format("truetype"),url("https://use.fontawesome.com/releases/v5.9.0/webfonts/fa-regular-400.svg#fontawesome") format("svg");unicode-range:U+F004-F005,U+F007,U+F017,U+F022,U+F024,U+F02E,U+F03E,U+F044,U+F057-F059,U+F06E,U+F070,U+F075,U+F07B-F07C,U+F080,U+F086,U+F089,U+F094,U+F09D,U+F0A0,U+F0A4-F0A7,U+F0C5,U+F0C7-F0C8,U+F0E0,U+F0EB,U+F0F3,U+F0F8,U+F0FE,U+F111,U+F118-F11A,U+F11C,U+F133,U+F144,U+F146,U+F14A,U+F14D-F14E,U+F150-F152,U+F15B-F15C,U+F164-F165,U+F185-F186,U+F191-F192,U+F1AD,U+F1C1-F1C9,U+F1CD,U+F1D8,U+F1E3,U+F1EA,U+F1F6,U+F1F9,U+F20A,U+F247-F249,U+F24D,U+F254-F25B,U+F25D,U+F267,U+F271-F274,U+F279,U+F28B,U+F28D,U+F2B5-F2B6,U+F2B9,U+F2BB,U+F2BD,U+F2C1-F2C2,U+F2D0,U+F2D2,U+F2DC,U+F2ED,U+F328,U+F358-F35B,U+F3A5,U+F3D1,U+F410,U+F4AD}</style> <script type='text/javascript'>ajaxurl='https://www.catholic.sg/wp-admin/admin-ajax.php';pf_nonce='9530b7088d'</script><script type='text/javascript' src='https://www.catholic.sg/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.catholic.sg/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='https://www.catholic.sg/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/plugins/birdseed/public/js/birdseed-public.js?ver=1.0.0'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='https://cdn.datatables.net/1.10.16/js/jquery.dataTables.min.js?ver=5.3'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='https://cdn.datatables.net/buttons/1.4.2/js/dataTables.buttons.min.js?ver=5.3'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='//cdn.datatables.net/buttons/1.4.2/js/buttons.colVis.min.js?ver=5.3'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='//cdn.datatables.net/buttons/1.4.2/js/buttons.print.min.js?ver=5.3'></script> <script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/pdfmake/0.1.32/pdfmake.min.js?ver=5.3'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/pdfmake/0.1.32/vfs_fonts.js?ver=5.3'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/jszip/3.1.3/jszip.min.js?ver=5.3'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='//cdn.datatables.net/buttons/1.4.2/js/buttons.html5.min.js?ver=5.3'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='https://cdn.datatables.net/select/1.2.3/js/dataTables.select.min.js?ver=5.3'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='https://cdn.datatables.net/fixedheader/3.1.3/js/dataTables.fixedHeader.min.js?ver=5.3'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='https://cdn.datatables.net/fixedcolumns/3.2.3/js/dataTables.fixedColumns.min.js?ver=5.3'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='https://cdn.datatables.net/responsive/2.2.0/js/dataTables.responsive.min.js?ver=5.3'></script> <script type='text/javascript'>var igsv_plugin_vars={"lang_dir":"https:\/\/www.catholic.sg\/wp-content\/plugins\/inline-google-spreadsheet-viewer\/languages","datatables_classes":".igsv-table:not(.no-datatables)","datatables_defaults_object":{"dom":"B<'clear'>lfrtip","buttons":["colvis","copy","csv","excel","pdf","print"]}}</script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-datatables.js?ver=5.3'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='//www.google.com/jsapi?ver=5.3'></script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-gvizcharts.js?ver=5.3'></script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/plugins/praybox-plus/js/jquery.pbx_public.js?ver=5.3'></script> <script type='text/javascript'>var wps_statistics_object={"rest_url":"https:\/\/www.catholic.sg\/wp-json\/","wpnonce":"581d6c1240"}</script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/plugins/wp-statistics/assets/js/front.min.js?ver=12.6.12'></script> <script type='text/javascript'>var objectL10n={"yopPollParams":{"urlParams":{"ajax":"https:\/\/www.catholic.sg\/wp-admin\/admin-ajax.php","wpLogin":"https:\/\/www.catholic.sg\/login\/?redirect_to=https%3A%2F%2Fwww.catholic.sg%2Fwp-admin%2Fadmin-ajax.php%3Faction%3Dyop_poll_record_wordpress_vote"},"apiParams":{"reCaptcha":{"siteKey":""},"reCaptchaV2Invisible":{"siteKey":""}},"captchaParams":{"imgPath":"https:\/\/www.catholic.sg\/wp-content\/plugins\/yop-poll\/public\/assets\/img\/","url":"https:\/\/www.catholic.sg\/wp-content\/plugins\/yop-poll\/app.php","accessibilityAlt":"Sound icon","accessibilityTitle":"Accessibility option: listen to a question and answer it!","accessibilityDescription":"Type below the <strong>answer<\/strong> to what you hear. Numbers or words:","explanation":"Click or touch the <strong>ANSWER<\/strong>","refreshAlt":"Refresh\/reload icon","refreshTitle":"Refresh\/reload: get new images and accessibility option!"},"voteParams":{"invalidPoll":"Invalid Pledge","noAnswersSelected":"No answer selected","minAnswersRequired":"At least {min_answers_allowed} answer(s) required","maxAnswersRequired":"A max of {max_answers_allowed} answer(s) accepted","noAnswerForOther":"No other answer entered","noValueForCustomField":"{custom_field_name} is required","consentNotChecked":"You must agree to our terms and conditions","noCaptchaSelected":"Captcha is required","thankYou":"Thank you for your pledge"},"resultsParams":{"singleVote":"person","multipleVotes":"persons","singleAnswer":"pledge","multipleAnswers":"pledges"}}}</script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/plugins/yop-poll/public/assets/js/yop-poll-public-6.1.4.min.js?ver=5.3'></script> <script type='text/javascript'>var sibErrMsg={"invalidMail":"Please fill out valid email address","requiredField":"Please fill out required fields","invalidDateFormat":"Please fill out valid date format","invalidSMSFormat":"Please fill out valid phone number"};var ajax_sib_front_object={"ajax_url":"https:\/\/www.catholic.sg\/wp-admin\/admin-ajax.php","ajax_nonce":"f84cdc7c5c","flag_url":"https:\/\/www.catholic.sg\/wp-content\/plugins\/mailin\/img\/flags\/"}</script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/plugins/mailin/js/mailin-front.js?ver=1573197363'></script> <link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.catholic.sg/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.catholic.sg/wp-includes/wlwmanifest.xml" /><link rel="canonical" href="https://www.catholic.sg/05-may-2020-tuesday-4th-week-of-easter/" /><link rel='shortlink' href='https://www.catholic.sg/?p=73405' /><link rel="alternate" type="application/json+oembed" href="https://www.catholic.sg/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.catholic.sg%2F05-may-2020-tuesday-4th-week-of-easter%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.catholic.sg/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.catholic.sg%2F05-may-2020-tuesday-4th-week-of-easter%2F&#038;format=xml" /> <script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};a2a_localize={Share:"Share",Save:"Save",Subscribe:"Subscribe",Email:"Email",Bookmark:"Bookmark",ShowAll:"Show All",ShowLess:"Show less",FindServices:"Find service(s)",FindAnyServiceToAddTo:"Instantly find any service to add to",PoweredBy:"Powered by",ShareViaEmail:"Share via email",SubscribeViaEmail:"Subscribe via email",BookmarkInYourBrowser:"Bookmark in your browser",BookmarkInstructions:"Press Ctrl+D or \u2318+D to bookmark this page",AddToYourFavorites:"Add to your favourites",SendFromWebOrProgram:"Send from any email address or email program",EmailProgram:"Email program",More:"More&#8230;",ThanksForSharing:"Thanks for sharing!",ThanksForFollowing:"Thanks for following!"};(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b)})(document,"script")</script> <script async src="https://www.googletagmanager.com/gtag/js?id=GA_TRACKING_ID"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments)}
gtag('js',new Date());gtag('config','GA_TRACKING_ID')</script> <meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.catholic.sg"><link rel="https://theeventscalendar.com/" href="https://www.catholic.sg/wp-json/tribe/events/v1/" /><style type="text/css" id="css-fb-visibility">@media screen and (max-width:640px){body:not(.fusion-builder-ui-wireframe) .fusion-no-small-visibility{display:none!important}}@media screen and (min-width:641px) and (max-width:1024px){body:not(.fusion-builder-ui-wireframe) .fusion-no-medium-visibility{display:none!important}}@media screen and (min-width:1025px){body:not(.fusion-builder-ui-wireframe) .fusion-no-large-visibility{display:none!important}}</style><style id="fusion-stylesheet-custom-css" type="text/css">body.single .post-slideshow .slides li{pointer-events:none}.fusion-footer-widget-area a:before{display:none}.fusion-footer-widget-area a{font-size:13px;line-height:80%}.fusion-footer-widget-area .widget-title{font-size:15px;font-weight:400;font-style:normal}.size-recent-posts img{width:100%;height:225px;object-fit:cover}.attachment-full img{width:100%;height:auto;object-fit:cover}.fusion-post-slideshow{width:100%;overflow:hidden}.fusion-post-content-container,.recent-posts-content p{font-size:14px}.comment-form-cookies-consent{display:none}</style> <script type="text/javascript">var doc=document.documentElement;doc.setAttribute('data-useragent',navigator.userAgent)</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=!0;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f)})(window,document,'script','dataLayer','GTM-WCG6FB3')</script> </head><body class="post-template-default single single-post postid-73405 single-format-standard tribe-no-js tribe-theme-Avada fusion-image-hovers fusion-pagination-sizing fusion-button_size-xlarge fusion-button_type-flat fusion-button_span-no avada-image-rollover-circle-yes avada-image-rollover-no avada fusion-body ltr fusion-sticky-header no-mobile-slidingbar no-mobile-totop avada-has-rev-slider-styles fusion-disable-outline fusion-sub-menu-fade mobile-logo-pos-center layout-wide-mode avada-has-boxed-modal-shadow-none layout-scroll-offset-full avada-has-zero-margin-offset-top fusion-top-header menu-text-align-left mobile-menu-design-modern fusion-show-pagination-text fusion-header-layout-v5 avada-responsive avada-footer-fx-sticky avada-menu-highlight-style-bar fusion-search-form-classic fusion-main-menu-search-dropdown fusion-avatar-square avada-sticky-shrinkage avada-dropdown-styles avada-blog-layout-large avada-blog-archive-layout-large avada-ec-not-100-width avada-ec-meta-layout-sidebar avada-header-shadow-yes avada-menu-icon-position-left avada-has-mainmenu-dropdown-divider avada-has-mobile-menu-search avada-has-main-nav-search-icon avada-has-breadcrumb-mobile-hidden avada-has-titlebar-hide avada-has-pagination-padding avada-flyout-menu-direction-right">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a><div id="boxed-wrapper"><div class="fusion-sides-frame"></div><div id="wrapper" class="fusion-wrapper"><div id="home" style="position:relative;top:-1px;"></div>
<header class="fusion-header-wrapper fusion-header-shadow"><div class="fusion-header-v5 fusion-logo-alignment fusion-logo-center fusion-sticky-menu- fusion-sticky-logo-1 fusion-mobile-logo-1 fusion-sticky-menu-and-logo fusion-header-menu-align-left fusion-mobile-menu-design-modern"><div class="fusion-secondary-header"><div class="fusion-row"><div class="fusion-alignright">
<nav class="fusion-secondary-menu" role="navigation" aria-label="Secondary Menu"></nav></div></div></div><div class="fusion-header-sticky-height"></div><div class="fusion-sticky-header-wrapper"><div class="fusion-header"><div class="fusion-row"><div class="fusion-logo" data-margin-top="0px" data-margin-bottom="5px" data-margin-left="0px" data-margin-right="0px">
<a class="fusion-logo-link" href="https://www.catholic.sg/">
<img src="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_tight_crop_280.png" srcset="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_tight_crop_280.png 1x" width="280" height="103" alt="Roman Catholic Archdiocese of Singapore Logo" data-retina_logo_url="" class="fusion-standard-logo" />
<img src="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_tight_crop_200.png" srcset="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_tight_crop_200.png 1x" width="200" height="74" alt="Roman Catholic Archdiocese of Singapore Logo" data-retina_logo_url="" class="fusion-mobile-logo" />
<img src="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_no_wordings_65.png" srcset="https://www.catholic.sg/wp-content/uploads/2019/07/Archdiocese_coat_of_arms_no_wordings_65.png 1x, https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-114.png 2x" width="65" height="65" style="max-height:65px;height:auto;" alt="Roman Catholic Archdiocese of Singapore Logo" data-retina_logo_url="https://www.catholic.sg/wp-content/uploads/2016/05/Archd-logo-col-web-trans-114.png" class="fusion-sticky-logo" />
</a></div><div class="fusion-mobile-menu-icons">
<a href="#" class="fusion-icon fusion-icon-bars" aria-label="Toggle mobile menu" aria-expanded="false"></a>
<a href="#" class="fusion-icon fusion-icon-search" aria-label="Toggle mobile search"></a></div></div></div><div class="fusion-secondary-main-menu"><div class="fusion-row">
<nav class="fusion-main-menu" aria-label="Main Menu"><ul id="menu-main-menu-v1-0" class="fusion-menu"><li id="menu-item-59777" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59777 fusion-dropdown-menu" data-item-id="59777"><a href="#" class="fusion-bar-highlight"><span class="menu-text">ABOUT</span></a><ul role="menu" class="sub-menu"><li id="menu-item-59778" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59778 fusion-dropdown-submenu"><a href="https://www.catholic.sg/about/" class="fusion-bar-highlight"><span>Our Archdiocese</span></a></li><li id="menu-item-59780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59780 fusion-dropdown-submenu"><a target="_blank" rel="noopener noreferrer" href="http://history.catholic.sg/" class="fusion-bar-highlight"><span>Our History</span></a></li><li id="menu-item-59781" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59781 fusion-dropdown-submenu"><a href="https://www.catholic.sg/our-channels/" class="fusion-bar-highlight"><span>Our Channels</span></a></li><li id="menu-item-65125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65125 fusion-dropdown-submenu"><a href="https://www.catholic.sg/notices/" class="fusion-bar-highlight"><span>Latest Notices &#038; Messages</span></a></li></ul></li><li id="menu-item-59720" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59720 fusion-dropdown-menu" data-item-id="59720"><a href="#" class="fusion-bar-highlight"><span class="menu-text">OUR FAITH</span></a><ul role="menu" class="sub-menu"><li id="menu-item-10928" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10928 fusion-dropdown-submenu"><a href="https://www.catholic.sg/our-faith/" class="fusion-bar-highlight"><span>Introduction</span></a></li><li id="menu-item-11973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11973 fusion-dropdown-submenu"><a href="https://www.catholic.sg/our-faith/catholic-stance-towards-non-christian-religions/" class="fusion-bar-highlight"><span>Catholic Stance Towards Non-Christian Religions</span></a></li><li id="menu-item-13624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13624 fusion-dropdown-submenu"><a href="https://www.catholic.sg/our-faith/declarationoffaith/" class="fusion-bar-highlight"><span>Declaration of Faith</span></a></li><li id="menu-item-10918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10918 fusion-dropdown-submenu"><a href="https://www.catholic.sg/our-faith/sacredscripture/" class="fusion-bar-highlight"><span>Sacred Scripture</span></a></li><li id="menu-item-50489" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-50489 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Liturgy</span></a><ul role="menu" class="sub-menu"><li id="menu-item-46147" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46147"><a href="https://www.catholic.sg/our-faith/liturgy/" class="fusion-bar-highlight"><span>Liturgical Policies</span></a></li><li id="menu-item-50490" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50490"><a href="https://www.catholic.sg/articles-liturgy/" class="fusion-bar-highlight"><span>Articles on Liturgy</span></a></li></ul></li><li id="menu-item-15822" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-15822 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Prayers</span></a><ul role="menu" class="sub-menu"><li id="menu-item-20017" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20017"><a href="/articles/a-meeting-of-hearts/" class="fusion-bar-highlight"><span>Why and How to Pray</span></a></li><li id="menu-item-16218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16218"><a href="https://www.catholic.sg/our-faith/thelordsprayer/" class="fusion-bar-highlight"><span>The Lord&#8217;s Prayer</span></a></li><li id="menu-item-15823" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15823"><a href="https://www.catholic.sg/our-faith/prayers/divine-office-lauds/" class="fusion-bar-highlight"><span>The Divine Office</span></a></li><li id="menu-item-18268" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18268"><a href="https://www.catholic.sg/our-faith/the-angelus/" class="fusion-bar-highlight"><span>The Angelus</span></a></li><li id="menu-item-43189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43189"><a href="https://www.catholic.sg/our-faith/prayerbook/" class="fusion-bar-highlight"><span>Our Prayer Book</span></a></li><li id="menu-item-15995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15995"><a href="https://www.catholic.sg/our-faith/otherprayers/" class="fusion-bar-highlight"><span>Other Prayers</span></a></li><li id="menu-item-10917" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10917"><a href="https://www.catholic.sg/our-faith/frequently-asked-questions/" class="fusion-bar-highlight"><span>FAQs About Faith</span></a></li></ul></li><li id="menu-item-59804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59804 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Resources</span></a><ul role="menu" class="sub-menu"><li id="menu-item-10916" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10916"><a href="https://www.catholic.sg/our-faith/resources/" class="fusion-bar-highlight"><span>Let&#8217;s Get Started!</span></a></li><li id="menu-item-12638" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12638"><a href="https://www.catholic.sg/our-faith/resources/knowing-the-faith/" class="fusion-bar-highlight"><span>Knowing the Faith</span></a></li><li id="menu-item-12639" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12639"><a href="https://www.catholic.sg/our-faith/resources/living-the-faith/" class="fusion-bar-highlight"><span>Living the Faith</span></a></li><li id="menu-item-21564" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21564"><a href="https://www.catholic.sg/our-faith/laudato-si-care-common-home/" class="fusion-bar-highlight"><span>Laudato Si&#8217;</span></a></li></ul></li></ul></li><li id="menu-item-59721" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59721 fusion-dropdown-menu" data-item-id="59721"><a href="#" class="fusion-bar-highlight"><span class="menu-text">PARTICIPATE</span></a><ul role="menu" class="sub-menu"><li id="menu-item-10964" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10964 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/" class="fusion-bar-highlight"><span>Introduction</span></a></li><li id="menu-item-60610" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60610 fusion-dropdown-submenu"><a href="https://www.catholic.sg/conversation/" class="fusion-bar-highlight"><span>CatholicSG Conversation</span></a></li><li id="menu-item-10962" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10962 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/becomingcatholic/" class="fusion-bar-highlight"><span>Becoming Catholic</span></a></li><li id="menu-item-10961" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10961 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/returning-catholics/" class="fusion-bar-highlight"><span>Returning Catholics</span></a></li><li id="menu-item-10960" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10960 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/new-evangelisation/" class="fusion-bar-highlight"><span>New Evangelisation</span></a></li><li id="menu-item-55947" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55947 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/share_rcia/" class="fusion-bar-highlight"><span>Share Our Faith</span></a></li><li id="menu-item-12130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12130 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/formation/" class="fusion-bar-highlight"><span>Faith Formation</span></a></li><li id="menu-item-10963" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10963 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/vocations/" class="fusion-bar-highlight"><span>Vocations</span></a></li><li id="menu-item-13518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13518 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/marriageandfamily/" class="fusion-bar-highlight"><span>Marriage &#038; Family</span></a></li><li id="menu-item-15671" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15671 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/youthandyoungadults/" class="fusion-bar-highlight"><span>Youths &#038; Young Adults</span></a></li><li id="menu-item-10959" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10959 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/catholic-schools/" class="fusion-bar-highlight"><span>Catholic Schools</span></a></li><li id="menu-item-59805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59805 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Let Us Pray&#8230;</span></a><ul role="menu" class="sub-menu"><li id="menu-item-12869" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12869"><a href="https://www.catholic.sg/get-assistance/pray-for-someone/" class="fusion-bar-highlight"><span>Pray for Someone</span></a></li><li id="menu-item-43881" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43881"><a href="https://www.catholic.sg/our-faith/prayerbook/" class="fusion-bar-highlight"><span>My Prayer Book</span></a></li></ul></li><li id="menu-item-19431" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19431 fusion-dropdown-submenu"><a href="https://www.catholic.sg/proud2b-2/" class="fusion-bar-highlight"><span>#proud2bCatholic</span></a></li><li id="menu-item-22291" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22291 fusion-dropdown-submenu"><a href="https://www.catholic.sg/participate/just-for-fun/" class="fusion-bar-highlight"><span>Just for Fun Quiz</span></a></li></ul></li><li id="menu-item-39462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39462 fusion-dropdown-menu" data-item-id="39462"><a href="#" class="fusion-bar-highlight"><span class="menu-text">ARTICLES</span></a><ul role="menu" class="sub-menu"><li id="menu-item-56264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56264 fusion-dropdown-submenu"><a target="_blank" rel="noopener noreferrer" href="https://stories.catholic.sg" class="fusion-bar-highlight"><span>Stories</span></a></li><li id="menu-item-56265" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56265 fusion-dropdown-submenu"><a href="https://www.catholic.sg/articles/" class="fusion-bar-highlight"><span>Reflections</span></a></li></ul></li><li id="menu-item-59722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59722 fusion-dropdown-menu" data-item-id="59722"><a href="#" class="fusion-bar-highlight"><span class="menu-text">EVENTS</span></a><ul role="menu" class="sub-menu"><li id="menu-item-12876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12876 fusion-dropdown-submenu"><a href="/events/" class="fusion-bar-highlight"><span>View Events</span></a></li><li id="menu-item-28925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-28925 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Publicise Event</span></a><ul role="menu" class="sub-menu"><li id="menu-item-28926" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28926"><a href="/events/announcement-advertisement-request/" class="fusion-bar-highlight"><span>Announcement &#038; Advertisement Request</span></a></li><li id="menu-item-28927" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28927"><a href="/events/publicise-event/" class="fusion-bar-highlight"><span>Event Submission Process</span></a></li></ul></li><li id="menu-item-13332" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13332 fusion-dropdown-submenu"><a href="https://www.catholic.sg/events/catholic-liturgical-calendar/" class="fusion-bar-highlight"><span>Catholic Liturgical Calendar</span></a></li><li id="menu-item-24850" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24850 fusion-dropdown-submenu"><a href="https://www.catholic.sg/events/confirmation-dates-2/" class="fusion-bar-highlight"><span>Confirmation Dates 2020</span></a></li><li id="menu-item-24851" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24851 fusion-dropdown-submenu"><a target="_blank" rel="noopener noreferrer" href="https://www.flickr.com/photos/catholicsg/albums" class="fusion-bar-highlight"><span>Event Photos</span></a></li><li id="menu-item-41035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41035 fusion-dropdown-submenu"><a href="https://www.catholic.sg/events/past-events/" class="fusion-bar-highlight"><span>Past Events &#038; Livestreams Archive</span></a></li></ul></li><li id="menu-item-59723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59723 fusion-dropdown-menu" data-item-id="59723"><a href="#" class="fusion-bar-highlight"><span class="menu-text">VISIT &#038; MASS</span></a><ul role="menu" class="sub-menu"><li id="menu-item-26500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26500 fusion-dropdown-submenu"><a href="https://www.catholic.sg/visit-mass/" class="fusion-bar-highlight"><span>Introduction</span></a></li><li id="menu-item-47694" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47694 fusion-dropdown-submenu"><a href="https://www.catholic.sg/visit-mass/livestream/" class="fusion-bar-highlight"><span>Livestream</span></a></li><li id="menu-item-24836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24836 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/find_mass/" class="fusion-bar-highlight"><span>Find A Mass</span></a></li><li id="menu-item-40449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40449 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/singapore-mass-schedule-catholic/" class="fusion-bar-highlight"><span>Mass Schedules</span></a></li><li id="menu-item-24837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24837 fusion-dropdown-submenu"><a href="https://www.catholic.sg/mass-readings/" class="fusion-bar-highlight"><span>Mass Readings</span></a></li><li id="menu-item-24838" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24838 fusion-dropdown-submenu"><a href="https://www.catholic.sg/visit-mass/the-order-of-mass/" class="fusion-bar-highlight"><span>The Order Of Mass</span></a></li><li id="menu-item-24852" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24852 fusion-dropdown-submenu"><a href="https://www.catholic.sg/visit-mass/days-of-obligation/" class="fusion-bar-highlight"><span>Days of Obligation &#038; Important Services</span></a></li><li id="menu-item-64226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64226 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/find_service/" class="fusion-bar-highlight"><span>Prayers, Devotions, &#038; Services</span></a></li><li id="menu-item-24854" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24854 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/go-for-confession/" class="fusion-bar-highlight"><span>Go for Confession</span></a></li></ul></li><li id="menu-item-59724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59724 fusion-dropdown-menu" data-item-id="59724"><a href="#" class="fusion-bar-highlight"><span class="menu-text">GET ASSISTANCE</span></a><ul role="menu" class="sub-menu"><li id="menu-item-24840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24840 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/" class="fusion-bar-highlight"><span>Social Services</span></a></li><li id="menu-item-70591" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-70591 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>COVID 19</span></a><ul role="menu" class="sub-menu"><li id="menu-item-68985" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68985"><a href="https://www.catholic.sg/coronavirus/" class="fusion-bar-highlight"><span>Updates &#038; Guidelines</span></a></li><li id="menu-item-71056" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71056"><a href="https://www.catholic.sg/faqs-on-the-suspension-of-mass/" class="fusion-bar-highlight"><span>FAQs on the suspension of Mass</span></a></li><li id="menu-item-71075" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71075"><a href="https://www.catholic.sg/offertory/" class="fusion-bar-highlight"><span>Church Donation</span></a></li><li id="menu-item-70594" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70594"><a href="https://www.catholic.sg/spiritual-resources-during-the-suspension-of-mass/" class="fusion-bar-highlight"><span>Online mass, devotions, &#038; resources</span></a></li><li id="menu-item-70595" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70595"><a href="https://www.catholic.sg/catholics-countering-covid-19/" class="fusion-bar-highlight"><span>Reflection Series</span></a></li></ul></li><li id="menu-item-72319" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72319 fusion-dropdown-submenu"><a href="https://www.catholic.sg/ministeringonline/" class="fusion-bar-highlight"><span>Ministering online through COVID-19</span></a></li><li id="menu-item-24846" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24846 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/getassistance-faqs/" class="fusion-bar-highlight"><span>Frequently Asked Questions</span></a></li><li id="menu-item-44444" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44444 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/hospital-pastoral-care/" class="fusion-bar-highlight"><span>Hospital Pastoral Care</span></a></li><li id="menu-item-24842" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24842 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/prayer-requests/" class="fusion-bar-highlight"><span>Ask for Prayers</span></a></li><li id="menu-item-40440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40440 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/programmes-by-catholic-church/" class="fusion-bar-highlight"><span>Programmes Provided</span></a></li><li id="menu-item-43719" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43719 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/support-services-by-catholic-church-in-singapore/" class="fusion-bar-highlight"><span>Support Services Provided</span></a></li><li id="menu-item-41718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41718 fusion-dropdown-submenu"><a href="https://www.catholic.sg/countering-fake-news/" class="fusion-bar-highlight"><span>Countering Fake News</span></a></li><li id="menu-item-51158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51158 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/report-an-incident/" class="fusion-bar-highlight"><span>Report an Incident</span></a></li><li id="menu-item-59806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59806 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Chancery Service</span></a><ul role="menu" class="sub-menu"><li id="menu-item-28211" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28211"><a href="http://chancery.catholic.sg/" class="fusion-bar-highlight"><span>About The Chancery</span></a></li><li id="menu-item-28216" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28216"><a href="https://chancery.catholic.sg/change-of-details/" class="fusion-bar-highlight"><span>Change Parish or Organisation Details</span></a></li><li id="menu-item-28212" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28212"><a href="https://chancery.catholic.sg/statement-suitability-ministry/" class="fusion-bar-highlight"><span>Statement of Suitability for Ministry</span></a></li><li id="menu-item-28214" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28214"><a href="https://chancery.catholic.sg/conflict-resolution-2/" class="fusion-bar-highlight"><span>Conflict Resolution Process</span></a></li><li id="menu-item-28215" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28215"><a href="https://chancery.catholic.sg/terms-parish-columbaria/" class="fusion-bar-highlight"><span>Terms for Parish Columbaria</span></a></li></ul></li><li id="menu-item-59807" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59807 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>Communication Services</span></a><ul role="menu" class="sub-menu"><li id="menu-item-35950" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35950"><a href="https://archcomms.catholic.sg/" class="fusion-bar-highlight"><span>ArchComms</span></a></li><li id="menu-item-35951" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35951"><a href="https://archcomms.catholic.sg/policies-guidelines/" class="fusion-bar-highlight"><span>Policies, Guidelines &#038; Copyright</span></a></li><li id="menu-item-35952" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35952"><a href="https://archcomms.catholic.sg/resources/" class="fusion-bar-highlight"><span>Other Resources</span></a></li><li id="menu-item-35953" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35953"><a href="https://archcomms.catholic.sg/request/" class="fusion-bar-highlight"><span>Request for Account</span></a></li></ul></li><li id="menu-item-44705" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44705 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/organisation-contact-details-information/?gr3ApI=502" class="fusion-bar-highlight"><span>Professional Standards Office</span></a></li><li id="menu-item-24845" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24845 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/search-support-services-singapore-catholic-church/" class="fusion-bar-highlight"><span>Other Support Services</span></a></li></ul></li><li id="menu-item-26814" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-26814 fusion-dropdown-menu" data-item-id="26814"><a href="#" class="fusion-bar-highlight"><span class="menu-text">DIRECTORY</span></a><ul role="menu" class="sub-menu"><li id="menu-item-24982" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24982 fusion-dropdown-submenu"><a href="/directory/singapore_catholic_church/" class="fusion-bar-highlight"><span>Church Directory</span></a></li><li id="menu-item-24983" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24983 fusion-dropdown-submenu"><a href="/directory/singapore_catholic_church/parish/" class="fusion-bar-highlight"><span>Parish Information</span></a></li><li id="menu-item-24848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24848 fusion-dropdown-submenu"><a href="https://www.catholic.sg/visit-mass/map-of-churches/" class="fusion-bar-highlight"><span>Map of Churches</span></a></li><li id="menu-item-26717" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26717 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/chapel-prayer-halls/" class="fusion-bar-highlight"><span>Chapel &#038; Prayer Halls</span></a></li><li id="menu-item-24857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24857 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/priest_clergy/" class="fusion-bar-highlight"><span>Priest / Clergy Listing</span></a></li><li id="menu-item-24859" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24859 fusion-dropdown-submenu"><a href="/directory/singapore_catholic_church/organisation-details/?G1ZTpe=Communities" class="fusion-bar-highlight"><span>Religious</span></a></li><li id="menu-item-24858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24858 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/sacerdotal_anniversaries/" class="fusion-bar-highlight"><span>Sacerdotal Anniversaries</span></a></li></ul></li><li id="menu-item-59725" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59725 fusion-dropdown-menu" data-item-id="59725"><a href="#" class="fusion-bar-highlight"><span class="menu-text">ARCHBISHOP</span></a><ul role="menu" class="sub-menu"><li id="menu-item-24889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24889 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/" class="fusion-bar-highlight"><span>Introduction</span></a></li><li id="menu-item-24885" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24885 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/about/" class="fusion-bar-highlight"><span>About</span></a></li><li id="menu-item-33602" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33602 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/from-vision-to-reality/" class="fusion-bar-highlight"><span>From Vision to Reality</span></a></li><li id="menu-item-24888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24888 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/scripture-reflection/" class="fusion-bar-highlight"><span>Daily Scripture Reflection</span></a></li><li id="menu-item-24878" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24878 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/pastoral-letters/" class="fusion-bar-highlight"><span>Pastoral Letters</span></a></li><li id="menu-item-24877" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24877 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/votive-homilies/" class="fusion-bar-highlight"><span>Votive Homilies</span></a></li><li id="menu-item-59811" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59811 fusion-dropdown-submenu"><a href="#" class="fusion-bar-highlight"><span>His Messages</span></a><ul role="menu" class="sub-menu"><li id="menu-item-24882" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24882"><a href="https://www.catholic.sg/archbishop/his-messages/current-events/" class="fusion-bar-highlight"><span>Current Events</span></a></li><li id="menu-item-24883" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24883"><a href="https://www.catholic.sg/archbishop/his-messages/catholic-occasions/" class="fusion-bar-highlight"><span>Catholic Occasions</span></a></li><li id="menu-item-24881" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24881"><a href="https://www.catholic.sg/archbishop/his-messages/other-occasions/" class="fusion-bar-highlight"><span>Other Occasions</span></a></li></ul></li><li id="menu-item-24884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24884 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/his-messages/speeches/" class="fusion-bar-highlight"><span>Speeches</span></a></li><li id="menu-item-24879" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24879 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/announcements-news/" class="fusion-bar-highlight"><span>Archbishop News</span></a></li><li id="menu-item-24887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24887 fusion-dropdown-submenu"><a href="https://www.catholic.sg/archbishop/video-gallery/" class="fusion-bar-highlight"><span>Video Gallery</span></a></li><li id="menu-item-24876" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24876 fusion-dropdown-submenu"><a target="_blank" rel="noopener noreferrer" href="https://www.catholic.sg/archbishop/cathedralofthegoodshepherd/" class="fusion-bar-highlight"><span>Cathedral of the Good Shepherd</span></a></li></ul></li><li id="menu-item-59782" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59782 fusion-dropdown-menu" data-item-id="59782"><a href="#" class="fusion-bar-highlight"><span class="menu-text">CONTACT</span></a><ul role="menu" class="sub-menu"><li id="menu-item-59783" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59783 fusion-dropdown-submenu"><a href="https://www.catholic.sg/contact/general/" class="fusion-bar-highlight"><span>General Enquiry</span></a></li><li id="menu-item-59784" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59784 fusion-dropdown-submenu"><a href="https://www.catholic.sg/contact/events/" class="fusion-bar-highlight"><span>Events Calendar Enquiry</span></a></li><li id="menu-item-59785" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59785 fusion-dropdown-submenu"><a href="https://www.catholic.sg/contact/directory/" class="fusion-bar-highlight"><span>Church Directory Enquiry</span></a></li><li id="menu-item-59786" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59786 fusion-dropdown-submenu"><a href="https://archcomms.catholic.sg/contact/?gr3ApI=513" class="fusion-bar-highlight"><span>Media Contact</span></a></li><li id="menu-item-59787" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59787 fusion-dropdown-submenu"><a href="https://www.catholic.sg/get-assistance/prayer-requests/" class="fusion-bar-highlight"><span>Prayer Requests Submissions</span></a></li><li id="menu-item-59788" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59788 fusion-dropdown-submenu"><a href="https://www.catholic.sg/directory/singapore_catholic_church/" class="fusion-bar-highlight"><span>Parishes/Organisations Contact</span></a></li><li id="menu-item-59790" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59790 fusion-dropdown-submenu"><a href="https://www.catholic.sg/donate/" class="fusion-bar-highlight"><span>Give</span></a></li></ul></li><li class="fusion-custom-menu-item fusion-main-menu-search"><a class="fusion-main-menu-icon fusion-bar-highlight" href="#" aria-label="Search" data-title="Search" title="Search"></a><div class="fusion-custom-menu-item-contents"><form role="search" class="searchform fusion-search-form fusion-live-search" method="get" action="https://www.catholic.sg/"><div class="fusion-search-form-content"><div class="fusion-search-field search-field">
<label><span class="screen-reader-text">Search for:</span>
<input type="search" value="" name="s" class="s" placeholder="Search ..." required aria-required="true" aria-label="Search ..." />
</label></div><div class="fusion-search-button search-button">
<input type="submit" class="fusion-search-submit searchsubmit" value="&#xf002;" /></div></div></form></div></li></ul></nav>
<nav class="fusion-mobile-nav-holder fusion-mobile-menu-text-align-left" aria-label="Main Menu Mobile"></nav><div class="fusion-clearfix"></div><div class="fusion-mobile-menu-search"><form role="search" class="searchform fusion-search-form fusion-live-search" method="get" action="https://www.catholic.sg/"><div class="fusion-search-form-content"><div class="fusion-search-field search-field">
<label><span class="screen-reader-text">Search for:</span>
<input type="search" value="" name="s" class="s" placeholder="Search ..." required aria-required="true" aria-label="Search ..." />
</label></div><div class="fusion-search-button search-button">
<input type="submit" class="fusion-search-submit searchsubmit" value="&#xf002;" /></div></div></form></div></div></div></div></div><div class="fusion-clearfix"></div>
</header><div id="sliders-container"></div><div class="avada-page-titlebar-wrapper"></div><main id="main" class="clearfix "><div class="fusion-row" style=""><section id="content" style="width: 100%;">
<article id="post-73405" class="post post-73405 type-post status-publish format-standard hentry category-scripture-reflection"><h1 class="entry-title fusion-post-title">05 May, 2020, Tuesday, 4th Week of Easter</h1><div class="post-content"><div class="fusion-fullwidth fullwidth-box fusion-builder-row-1 hundred-percent-fullwidth non-hundred-percent-height-scrolling" style='background-color: rgba(255,255,255,0);background-position: center center;background-repeat: no-repeat;'><div class="fusion-builder-row fusion-row "><div class="fusion-layout-column fusion_builder_column fusion_builder_column_1_1 fusion-builder-column-1 fusion-one-full fusion-column-first fusion-column-last fusion-column-no-min-height 1_1" style='margin-top:0px;margin-bottom:0px;'><div class="fusion-column-wrapper" style="padding: 0px 0px 0px 0px;background-position:left top;background-repeat:no-repeat;-webkit-background-size:cover;-moz-background-size:cover;-o-background-size:cover;background-size:cover;" data-bg-url=""><div class="fusion-column-content-centered"><div class="fusion-column-content"><style type="text/css"></style><div class="fusion-title title fusion-title-1 fusion-sep-none fusion-title-text fusion-title-size-one" style="margin-top:20px;margin-bottom:20px;"><h1 class="title-heading-left" style="margin:0;">A CHURCH THAT GOES OUT</h1></div><div class="fusion-text"><hr /><p>SCRIPTURE READINGS: [ Acts 11:19-26; Ps 87:1-7; John 10:22-30 ]</p></div><div class="fusion-text"><p style="text-align: justify"><strong>The greatest danger of the Catholic Church is that of being fossilized.  </strong>The Catholic Church is more than 2000 years old.  Singapore will only be 55 years old this year in August.  If we think 55 years is a long time, what do you think of the Church that is 2000 years old?  Indeed, it is awesome to know that the Catholic Church has a tradition of 2000 years.  And we are still in existence with more than 1.3 billion members.   In spite of setbacks due to scandals, we are still strong.  Yet, like any established organization, there is the temptation to complacency and routine.</p><p style="text-align: justify"><strong>This was the same struggle with Judaism during the time of Jesus.</strong>  Like the Catholic Church, Judaism by the time of Jesus also had a 2000-year tradition since the Exodus under the leadership of Moses.  The laws given by Moses were taught and upheld religiously by the faithful Jews.  Those who were more meticulous in observing the laws were called the Pharisees, which meant the &#8220;separated ones.&#8221;  The Jews understandably saw the need to preserve their religious and cultural tradition.  After all, race, culture and religion were deeply intertwined.  As a result, they became inward-looking, defensive of their religion, race and culture, excluding everyone else.  In wanting to be exclusive, they became fossilized as the only way they could expand was to reproduce among themselves.  At the same time, they cut themselves off from the rest of humanity.</p><p style="text-align: justify"><strong>However, the truth is that the Jews were the Chosen People of God, not just for themselves but for the sake of humanity.</strong>  They forgot that their role was to bring all people into the true knowledge of God. Isaiah prophesied, &#8220;I am the Lord, I have called you in righteousness, I have taken you by the hand and kept you; I have given you as a covenant to the people, a light to the nations, to open the eyes that are blind, to bring out the prisoners from the dungeon, from the prison those who sit in darkness.&#8221;  (Isa 42:6f)</p><p style="text-align: justify"><strong>But this cannot be realized except with a new Covenant in Christ.</strong> The Old Covenant was between God and the Israelites.  The New Covenant is between God and all of humanity.  At the Last Supper, the Lord said, &#8220;This is my blood of the covenant, which is poured out for many.&#8221;  (Mk 14:24)  Christ, then, is the fulfillment of Judaism.  He completes what Moses prophesied, &#8220;The Lord your God will raise up for you a prophet like me from among your own people; you shall heed such a prophet.&#8221;  (Dt 18:15)  He is the New Moses that gives us the Living Water, the Holy Spirit; the Manna from heaven, the Bread of Life, the One who walks on the water and saves us from the storms of life by calming the waters.  Indeed, He is the Messiah, the Son of God.  This is what the Lord claims today in the gospel.  When the Jews asked Him, &#8220;How much longer are you going to keep us in suspense? If you are the Christ, tell us plainly.&#8221;  Jesus replied, &#8220;The works I do in my Father&#8217;s name are my witness.  The Father who gave them to me is greater than anyone, and no one can steal from the Father.  The Father and I are one.&#8221;</p><p style="text-align: justify"><strong>But they could not accept because their minds were already fixated.  </strong>The Lord remarked, &#8220;but you do not believe, because you are no sheep of mine.&#8221;   It is significant that the Lord said these words at the Feast of Dedication.<strong>  </strong>This feast celebrates the restoration of the Temple that was desecrated by Antiochus Epiphanes in 170 B.C.  More than 80,000 Jews perished because of their faith.  It was a capital crime to possess a copy of the law or circumcise their children.  The Temple chambers were converted into brothels and Antiochus turned the great altar into an altar dedicated to Olympian Zeus.  It was Judas Maccabeus that won the fight against them and expelled them.  So, the Feast of the Dedication of the Temple was a memorial of the Purification of the Temple.   Christ now has come as the Light of the world.</p><p style="text-align: justify"><strong>Jesus came precisely to restore the New Temple of God.</strong> Jesus told the Jews at the Temple, &#8220;&#8216;Stop making my Father&#8217;s house a marketplace!&#8217; His disciples remembered that it was written, &#8216;Zeal for your house will consume me.&#8217; The Jews then said to him, &#8216;What sign can you show us for doing this?&#8221; Jesus answered them, &#8216;Destroy this temple, and in three days I will raise it up.'&#8221;  (Jn 2:16-19)  He is the Temple of God because in Him, God dwells fully.  This is because, as He said, &#8220;The Father and I are one.&#8221;  He is one with God.  Only He can reveal to us who our Father is and can reconcile us with Him.  In Christ, therefore, all of us are called to be One body.  St Paul wrote, &#8220;In Christ Jesus you are all children of God through faith. As many of you as were baptized into Christ have clothed yourselves with Christ.  There is no longer Jew or Greek, there is no longer slave or free, there is no longer male and female; for all of you are one in Christ Jesus. And if you belong to Christ, then you are Abraham&#8217;s offspring, heirs according to the promise.&#8221;  (Gal 3:26-29)</p><p style="text-align: justify"><strong>But this was the same challenge that the early Jewish Christians faced.  </strong>They were actually Jews who believed that Christ was the fulfilment of the promises made to Abraham and therefore completes Judaism.  Unfortunately, they still thought that to be saved, one must be a Jew and belong to Judaism.  This means that all the practices of Judaism must be carried out over and above faith in Jesus as the promised Messiah since the New Covenant is a continuity of the Old Covenant.  So they were really &#8220;Christian Jews&#8221; not &#8220;Jewish Christians.&#8221;  In other words, they were first and foremost Jews and then Christians.  Hence, to be a Christian, one must first be a Jew.  This, of course, would exclude all the Gentiles.</p><p style="text-align: justify"><strong>However, thanks to the Holy Spirit, their mindset was gradually broadened.</strong>  They came to realize that being a Christian was more important than being a Jew.  One can be a Jewish Christian, a Chinese Christian, an Indian Christian.  Being a Christian is not identified with a culture or a race or a nationality.   We are identified with Christ.  We read that &#8220;it was at Antioch that the disciples were first called &#8216;Christians&#8217;.&#8221;  This is because all can be disciples of Jesus without being a Jew.   Hence, we not only call ourselves, Christians but &#8220;Catholics&#8221;, meaning, universal.</p><p style="text-align: justify"><strong>This was the consequence of the early Church reaching out.</strong>  Initially, they only preached the gospel to the Jews because it was thought that they were the Chosen People of God.   But the Holy Spirit pushed them to preach the gospel beyond the Jews.  Philip went to Samaria to preach to the half-Jews since they intermarried with the pagans.  Next, the Holy Spirit prepared Peter to welcome Cornelius into the faith.  He was not a Jew but he was a God-fearing man.   Then with the persecution, the gospel was preached to the Gentiles.  Those who had escaped &#8220;travelled as far as Phoenicia and Cyprus and Antioch, but they usually proclaimed the message only to Jews. Some of them, however, who came from Cyprus and Cyrene went to Antioch where they started preaching to the Greeks, proclaiming the Good News of the Lord Jesus to them as well. The Lord helped them, and a great number believed and were converted to the Lord.&#8221;   This was the beginning of Christianity becoming a world-wide religion.</p><p style="text-align: justify"><strong>What is the great lesson for us as Church today?  We must go beyond ourselves.</strong> The Church cannot be a refuge for insecure people who gather together day after day, week after week like a small conclave taking care of herself and each other.  Rather, the Church must be missionary-minded.  To survive, we must grow.  To grow we must intentionally reach out beyond our narrow confines.  We are called to bring the gospel to all the nations.  We should be proactive and make the necessary changes to the structure and traditions of the Church whenever possible and as necessary.  Of course, the Big Tradition of the Christian Faith cannot be changed.  Those doctrines are non-negotiable.  But many things we do in the Church, governance, means of catechesis and evangelization, devotional practices and even liturgical practices must change to meet the new challenges of our time.  If we are fearful of reaching out and just want to close in on ourselves, we will find the Catholic Faith becoming irrelevant in the world.  Perhaps we should thank God that the Church is now being persecuted again because it serves to purify and strengthen our Catholics, wake us up from our complacency and force us to listen to His voice anew.  May we be renewed and purified once again.</p></div></div></div><div class="fusion-clearfix"></div></div></div><div class="fusion-layout-column fusion_builder_column fusion_builder_column_1_1 fusion-builder-column-2 fusion-one-full fusion-column-first fusion-column-last 1_1" style='margin-top:0px;margin-bottom:20px;'><div class="fusion-column-wrapper" style="padding: 0px 0px 0px 0px;background-position:left top;background-repeat:no-repeat;-webkit-background-size:cover;-moz-background-size:cover;-o-background-size:cover;background-size:cover;" data-bg-url=""><div class="fusion-text"><hr /><p><span style="font-size: 10pt">Written by The Most Rev William Goh, Roman Catholic Archbishop of Singapore &copy; All Rights Reserved</span></p><hr /></div><div class="fusion-clearfix"></div></div></div><div class="fusion-layout-column fusion_builder_column fusion_builder_column_1_1 fusion-builder-column-3 fusion-one-full fusion-column-first fusion-column-last fusion-column-no-min-height 1_1" style='margin-top:20px;margin-bottom:20px;'><div class="fusion-column-wrapper" style="background-color:#e3f1f4;padding: 20px 20px 20px 20px;background-position:left top;background-repeat:no-repeat;-webkit-background-size:cover;-moz-background-size:cover;-o-background-size:cover;background-size:cover;" data-bg-url=""><style type="text/css"></style><div class="fusion-title title fusion-title-2 fusion-sep-none fusion-title-text fusion-title-size-five" style="margin-top:0px;margin-bottom:0px;"><h5 class="title-heading-left" style="margin:0;">Best Practices for Using the Daily Scripture Reflections</h5></div><div class="fusion-text"><ul><li><span style="font-size: 8pt"><em>Encounter God through the spirit of prayer and the scripture by reflecting and praying the Word of God daily. The purpose is to bring you to prayer and to a deeper union with the Lord on the level of the heart.</em></span></li><li><span style="font-size: 8pt"><em>Daily reflections when archived will lead many to accumulate all the reflections of the week and pray in one sitting. This will compromise your capacity to enter deeply into the Word of God, as the tendency is to read for knowledge rather than a prayerful reading of the Word for the purpose of developing a personal and affective relationship with the Lord.</em></span></li><li><span style="font-size: 8pt"><em>It is more important to pray deeply, not read widely. The current reflections of the day would be more than sufficient for anyone who wants to pray deeply and be led into an intimacy with the Lord.</em></span></li></ul><p><span style="font-size: 8pt"><em>Note: You may share this reflection with someone. However, please note that reflections are not archived online nor will they be available via email request.</em></span></p></div><div class="fusion-clearfix"></div></div></div></div></div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="addtoany_header">Share This!</div><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.catholic.sg/05-may-2020-tuesday-4th-week-of-easter/" data-a2a-title="05 May, 2020, Tuesday, 4th Week of Easter"><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fwww.catholic.sg%2F05-may-2020-tuesday-4th-week-of-easter%2F&amp;linkname=05%20May%2C%202020%2C%20Tuesday%2C%204th%20Week%20of%20Easter" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.catholic.sg%2F05-may-2020-tuesday-4th-week-of-easter%2F&amp;linkname=05%20May%2C%202020%2C%20Tuesday%2C%204th%20Week%20of%20Easter" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_messenger" href="https://www.addtoany.com/add_to/facebook_messenger?linkurl=https%3A%2F%2Fwww.catholic.sg%2F05-may-2020-tuesday-4th-week-of-easter%2F&amp;linkname=05%20May%2C%202020%2C%20Tuesday%2C%204th%20Week%20of%20Easter" title="Facebook Messenger" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_google_gmail" href="https://www.addtoany.com/add_to/google_gmail?linkurl=https%3A%2F%2Fwww.catholic.sg%2F05-may-2020-tuesday-4th-week-of-easter%2F&amp;linkname=05%20May%2C%202020%2C%20Tuesday%2C%204th%20Week%20of%20Easter" title="Gmail" rel="nofollow noopener" target="_blank"></a></div></div></div><span class="vcard rich-snippet-hidden"><span class="fn"><a href="https://www.catholic.sg/author/trcas-pa/" title="Posts by Magdalene Lee" rel="author">Magdalene Lee</a></span></span><span class="updated rich-snippet-hidden">2020-05-05T01:02:00+08:00</span>
</article>
</section></div>
</main><div class="fusion-footer">
<footer class="fusion-footer-widget-area fusion-widget-area"><div class="fusion-row"><div class="fusion-columns fusion-columns-3 fusion-widget-area"><div class="fusion-column col-lg-4 col-md-4 col-sm-4"><style type="text/css" data-id="nav_menu-48">@media (max-width:800px){#nav_menu-48{text-align:initial!important}}</style><section id="nav_menu-48" class="fusion-widget-mobile-align-initial fusion-widget-align-left fusion-footer-widget-column widget widget_nav_menu" style="text-align: left;"><h4 class="widget-title">Admin Links</h4><div class="menu-footer-left-container"><ul id="menu-footer-left" class="menu"><li id="menu-item-59871" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59871"><a target="_blank" rel="noopener noreferrer" href="http://intranet.catholic.sg/">Archdiocese Intranet</a></li><li id="menu-item-59872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59872"><a href="https://www.catholic.sg/login/">Website Login</a></li><li id="menu-item-59873" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59873"><a href="https://www.catholic.sg/pdpa-policy/">Archdiocese PDPA Policy</a></li><li id="menu-item-59874" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59874"><a href="https://www.catholic.sg/terms/">Terms &#038; Conditions</a></li></ul></div><div style="clear:both;"></div></section></div><div class="fusion-column col-lg-4 col-md-4 col-sm-4"><style type="text/css" data-id="nav_menu-49">@media (max-width:800px){#nav_menu-49{text-align:initial!important}}</style><section id="nav_menu-49" class="fusion-widget-mobile-align-initial fusion-widget-align-center fusion-footer-widget-column widget widget_nav_menu" style="text-align: center;"><h4 class="widget-title">Vibrant, Evangelising, &#038; Missionary Church</h4><div class="menu-footer-centre-container"><ul id="menu-footer-centre" class="menu"><li id="menu-item-59875" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59875"><a href="https://www.catholic.sg/donate/">Donate Now</a></li><li id="menu-item-59876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59876"><a href="https://www.catholic.sg/seek-opportunities/">Work &#038; Volunteer Opportunities</a></li></ul></div><div style="clear:both;"></div></section></div><div class="fusion-column fusion-column-last col-lg-4 col-md-4 col-sm-4"><style type="text/css" data-id="nav_menu-51">@media (max-width:800px){#nav_menu-51{text-align:initial!important}}</style><section id="nav_menu-51" class="fusion-widget-mobile-align-initial fusion-widget-align-right fusion-footer-widget-column widget widget_nav_menu" style="text-align: right;"><h4 class="widget-title">Archdiocese Media</h4><div class="menu-footer-right-container"><ul id="menu-footer-right" class="menu"><li id="menu-item-59885" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59885"><a href="https://www.catholic.sg/participate/bulletin/">Archdiocese eBulletin</a></li><li id="menu-item-59886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59886"><a target="_blank" rel="noopener noreferrer" href="https://catholicnews.sg/">Catholic News</a></li><li id="menu-item-59887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59887"><a href="https://radio.catholic.sg">Catholic Radio</a></li><li id="menu-item-59888" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59888"><a href="https://www.catholic.sg/our-channels/">Social Media</a></li></ul></div><div style="clear:both;"></div></section></div><div class="fusion-clearfix"></div></div></div>
</footer>
<footer id="footer" class="fusion-footer-copyright-area"><div class="fusion-row"><div class="fusion-copyright-content"><div class="fusion-copyright-notice"><div>
© 2014-2020 Roman Catholic Archdiocese of Singapore.  All Rights Reserved.</div></div><div class="fusion-social-links-footer"><div class="fusion-social-networks"><div class="fusion-social-networks-wrapper"><a class="fusion-social-network-icon fusion-tooltip fusion-facebook fusion-icon-facebook" style href="https://www.facebook.com/Catholic.Sg" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="Facebook" data-toggle="tooltip" title="Facebook"><span class="screen-reader-text">Facebook</span></a><a class="fusion-social-network-icon fusion-tooltip fusion-twitter fusion-icon-twitter" style href="https://twitter.com/catholicssg" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="Twitter" data-toggle="tooltip" title="Twitter"><span class="screen-reader-text">Twitter</span></a><a class="fusion-social-network-icon fusion-tooltip fusion-instagram fusion-icon-instagram" style href="https://instagram.com/catholic.sg/" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="Instagram" data-toggle="tooltip" title="Instagram"><span class="screen-reader-text">Instagram</span></a><a class="fusion-social-network-icon fusion-tooltip fusion-youtube fusion-icon-youtube" style href="https://www.youtube.com/user/CatholicsSg" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="YouTube" data-toggle="tooltip" title="YouTube"><span class="screen-reader-text">YouTube</span></a><a class="fusion-social-network-icon fusion-tooltip fusion-flickr fusion-icon-flickr" style href="https://www.flickr.com/photos/catholicsg/albums" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="Flickr" data-toggle="tooltip" title="Flickr"><span class="screen-reader-text">Flickr</span></a><a class="fusion-social-network-icon fusion-tooltip fusion-linkedin fusion-icon-linkedin fusion-last-social-icon" style href="https://www.linkedin.com/company/catholicsg" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="LinkedIn" data-toggle="tooltip" title="LinkedIn"><span class="screen-reader-text">LinkedIn</span></a><a class="custom fusion-social-network-icon fusion-tooltip fusion-custom fusion-icon-custom" style="position:relative;" href="https://www.catholic.sg/install-telegram/" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="Telegram" data-toggle="tooltip" title="Telegram"><span class="screen-reader-text">Telegram</span><img src="https://www.catholic.sg/wp-content/uploads/2019/07/telegram_grey.png" style="width:auto;" alt="Telegram" /></a><a class="custom fusion-social-network-icon fusion-tooltip fusion-custom fusion-icon-custom" style="position:relative;" href="https://www.catholic.sg/radio/" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="CatholicSG Radio" data-toggle="tooltip" title="CatholicSG Radio"><span class="screen-reader-text">CatholicSG Radio</span><img src="https://www.catholic.sg/wp-content/uploads/2019/07/CSG_radio.png" style="width:auto;" alt="CatholicSG Radio" /></a><a class="custom fusion-social-network-icon fusion-tooltip fusion-custom fusion-icon-custom" style="position:relative;" href="https://app.catholic.sg/" target="_blank" rel="noopener noreferrer" data-placement="top" data-title="CatholicSG App" data-toggle="tooltip" title="CatholicSG App"><span class="screen-reader-text">CatholicSG App</span><img src="https://www.catholic.sg/wp-content/uploads/2019/07/catholicSG_grey.png" style="width:auto;" alt="CatholicSG App" /></a></div></div></div></div></div>
</footer></div><div class="fusion-sliding-bar-wrapper"></div></div></div><div class="fusion-top-frame"></div><div class="fusion-bottom-frame"></div><div class="fusion-boxed-shadow"></div>
<a class="fusion-one-page-text-link fusion-page-load-link"></a><div class="avada-footer-scripts"><style>.comment-form-url,#url{display:none}</style><style>.comment-form-email,#email{display:none}</style><script>var refTagger={settings:{bibleVersion:"RSVCE",libronixBibleVersion:"RSVCE",addLogosLink:!1,appendIconToLibLinks:!1,libronixLinkIcon:"dark",noSearchClassNames:[],useTooltip:!0,noSearchTagNames:["h1","h2","h3"],linksOpenNewWindow:!0,convertHyperlinks:!1,caseInsensitive:!0,tagChapters:!0}};(function(d,t){var g=d.createElement(t),s=d.getElementsByTagName(t)[0];g.src='//api.reftagger.com/v2/reftagger.js';s.parentNode.insertBefore(g,s)}(document,'script'))</script> <script>(function(body){'use strict';body.className=body.className.replace(/\btribe-no-js\b/,'tribe-js')})(document.body)</script> <script type="text/javascript">var recaptcha_widgets={};function wp_recaptchaLoadCallback(){try{grecaptcha}catch(err){return}
var e=document.querySelectorAll?document.querySelectorAll('.g-recaptcha:not(.wpcf7-form-control)'):document.getElementsByClassName('g-recaptcha'),form_submits;for(var i=0;i<e.length;i++){(function(el){var wid;if(!el.childNodes.length){wid=grecaptcha.render(el,{'sitekey':'6Lcu8gETAAAAAOV74Tc_XObQffW4HYlhErAPrA_D','theme':el.getAttribute('data-theme')||'light'});el.setAttribute('data-widget-id',wid)}else{wid=el.getAttribute('data-widget-id');grecaptcha.reset(wid)}})(e[i])}}
if(typeof jQuery!=='undefined')
jQuery(document).ajaxComplete(function(evt,xhr,set){if(xhr.responseText&&xhr.responseText.indexOf('6Lcu8gETAAAAAOV74Tc_XObQffW4HYlhErAPrA_D')!==-1)
wp_recaptchaLoadCallback()})</script><script src="https://www.google.com/recaptcha/api.js?onload=wp_recaptchaLoadCallback&#038;render=explicit" async defer></script> <script>var tribe_l10n_datatables={"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}}</script><script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=3'></script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/plugins/the-events-calendar/common/src/resources/js/tribe-common.min.js?ver=4.9.21'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='https://www.catholic.sg/wp-content/plugins/the-events-calendar/common/src/resources/js/tooltip.min.js?ver=4.9.21'></script> <script type='text/javascript'>var wpcf7={"apiSettings":{"root":"https:\/\/www.catholic.sg\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"}</script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script> <script data-wpacu-to-be-preloaded-basic='1' type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6Lf3BMUUAAAAAMzF2qHrx-r0Y7uRpp0q-dnjS-Jb&#038;ver=3.0'></script> <script type='text/javascript' src='https://www.catholic.sg/wp-content/uploads/fusion-scripts/95c7d6d3d3551f83e9a82f4dc66b6e63.min.js?ver=2.1.1'></script> <script type='text/javascript' src='https://www.catholic.sg/wp-includes/js/wp-embed.min.js?ver=5.3'></script> <script type="text/javascript">(function(grecaptcha,sitekey,actions){var wpcf7recaptcha={execute:function(action){grecaptcha.execute(sitekey,{action:action}).then(function(token){var forms=document.getElementsByTagName('form');for(var i=0;i<forms.length;i++){var fields=forms[i].getElementsByTagName('input');for(var j=0;j<fields.length;j++){var field=fields[j];if('g-recaptcha-response'===field.getAttribute('name')){field.setAttribute('value',token);break}}}})},executeOnHomepage:function(){wpcf7recaptcha.execute(actions.homepage)},executeOnContactform:function(){wpcf7recaptcha.execute(actions.contactform)},};grecaptcha.ready(wpcf7recaptcha.executeOnHomepage);document.addEventListener('change',wpcf7recaptcha.executeOnContactform,!1);document.addEventListener('wpcf7submit',wpcf7recaptcha.executeOnHomepage,!1)})(grecaptcha,'6Lf3BMUUAAAAAMzF2qHrx-r0Y7uRpp0q-dnjS-Jb',{"homepage":"homepage","contactform":"contactform"})</script> <script type="text/javascript">jQuery(document).ready(function(){var ajaxurl='https://www.catholic.sg/wp-admin/admin-ajax.php';if(0<jQuery('.fusion-login-nonce').length){jQuery.get(ajaxurl,{'action':'fusion_login_nonce'},function(response){jQuery('.fusion-login-nonce').html(response)})}})</script> <script defer id="io.birdseed.script-tag" type="text/javascript" src="https://app.birdseed.io/widget.js"></script><div id="birdseed-widget-container" data-token="da71e1f11ea1e9d3ee4086bc4279d1b6"></div>
<noscript><iframe
src="https://www.googletagmanager.com/ns.html?id=GTM-WCG6FB3"
height="0" width="0" style="display:none;visibility:hidden;"></iframe></noscript><meta name="wpacu-generator" content="ASSET CLEANUP NOSCRIPT FOR ASYNC PRELOADS"><meta name="wpacu-generator" content="ASSET CLEANUP NOSCRIPT WEB FONT LOADER"></div></body></html>




